summaryrefslogtreecommitdiffstats
path: root/vendor/getrandom-0.1.16/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /vendor/getrandom-0.1.16/Cargo.toml
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/getrandom-0.1.16/Cargo.toml')
-rw-r--r--vendor/getrandom-0.1.16/Cargo.toml69
1 files changed, 0 insertions, 69 deletions
diff --git a/vendor/getrandom-0.1.16/Cargo.toml b/vendor/getrandom-0.1.16/Cargo.toml
deleted file mode 100644
index e3f413ae4..000000000
--- a/vendor/getrandom-0.1.16/Cargo.toml
+++ /dev/null
@@ -1,69 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
-#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
-
-[package]
-edition = "2018"
-name = "getrandom"
-version = "0.1.16"
-authors = ["The Rand Project Developers"]
-exclude = ["utils/*", ".*", "appveyor.yml"]
-description = "A small cross-platform library for retrieving random data from system source"
-documentation = "https://docs.rs/getrandom"
-categories = ["os", "no-std"]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/rust-random/getrandom"
-[dependencies.cfg-if]
-version = "1"
-
-[dependencies.compiler_builtins]
-version = "0.1"
-optional = true
-
-[dependencies.core]
-version = "1.0"
-optional = true
-package = "rustc-std-workspace-core"
-
-[dependencies.log]
-version = "0.4"
-optional = true
-
-[features]
-dummy = []
-rustc-dep-of-std = ["compiler_builtins", "core"]
-std = []
-test-in-browser = ["wasm-bindgen"]
-wasm-bindgen = ["bindgen", "js-sys"]
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
-version = "0.9"
-[target."cfg(unix)".dependencies.libc]
-version = "0.2.64"
-default-features = false
-[target.wasm32-unknown-unknown.dependencies.bindgen]
-version = "0.2.29"
-optional = true
-package = "wasm-bindgen"
-
-[target.wasm32-unknown-unknown.dependencies.js-sys]
-version = "0.3"
-optional = true
-
-[target.wasm32-unknown-unknown.dependencies.stdweb]
-version = "0.4.18"
-optional = true
-[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen-test]
-version = "0.2"
-[badges.appveyor]
-repository = "rust-random/getrandom"
-
-[badges.travis-ci]
-repository = "rust-random/getrandom"