summaryrefslogtreecommitdiffstats
path: root/vendor/git2-curl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:36 +0000
commite02c5b5930c2c9ba3e5423fe12e2ef0155017297 (patch)
treefd60ebbbb5299e16e5fca8c773ddb74f764760db /vendor/git2-curl
parentAdding debian version 1.73.0+dfsg1-1. (diff)
downloadrustc-e02c5b5930c2c9ba3e5423fe12e2ef0155017297.tar.xz
rustc-e02c5b5930c2c9ba3e5423fe12e2ef0155017297.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/git2-curl')
-rw-r--r--vendor/git2-curl/.cargo-checksum.json2
-rw-r--r--vendor/git2-curl/CHANGELOG.md5
-rw-r--r--vendor/git2-curl/Cargo.toml4
-rw-r--r--vendor/git2-curl/src/lib.rs2
4 files changed, 9 insertions, 4 deletions
diff --git a/vendor/git2-curl/.cargo-checksum.json b/vendor/git2-curl/.cargo-checksum.json
index 890201873..8b2813794 100644
--- a/vendor/git2-curl/.cargo-checksum.json
+++ b/vendor/git2-curl/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"CHANGELOG.md":"f6f84d652ab203ceab1d7b2bbd74b3377ab0f6427953e351ef913a6c1ec4341e","Cargo.toml":"72640f80cabc15e50db969c34e33cd46137d20e5b9affc05922030598fc661ac","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","src/lib.rs":"ceba74be9bcb8644b372693bea460ae869411a6036fd49b52f99d130dfc18180","tests/all.rs":"5b48bca5608c533f4763f850a9b838cffe09e73e529261f16c331e10296f8e14"},"package":"f8f8b7432b72928cff76f69e59ed5327f94a52763731e71274960dee72fe5f8c"} \ No newline at end of file
+{"files":{"CHANGELOG.md":"dc92dbfd7cacd15ab298a25a11a80032f54f4c7620659f1e3a0b93d8a5295e38","Cargo.toml":"a8235f84191e13c8741de150c677fc5886f3e165ad864af06398865974d59693","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","src/lib.rs":"910337b5568cce283625328324f26a8754a3a6e3be2be5be6421ba4a47a7797d","tests/all.rs":"5b48bca5608c533f4763f850a9b838cffe09e73e529261f16c331e10296f8e14"},"package":"78e26b61608c573ffd26fc79061a823aa5147449a1afe1f61679a21e2031f7c3"} \ No newline at end of file
diff --git a/vendor/git2-curl/CHANGELOG.md b/vendor/git2-curl/CHANGELOG.md
index f20930568..98867bc28 100644
--- a/vendor/git2-curl/CHANGELOG.md
+++ b/vendor/git2-curl/CHANGELOG.md
@@ -1,5 +1,10 @@
# Changelog
+## 0.19.0 - 2023-08-28
+[0.18.0...0.19.0](https://github.com/rust-lang/git2-rs/compare/git2-curl-0.18.0...git2-curl-0.19.0)
+
+- Updated to [git2 0.18.0](../CHANGELOG.md#0180---2023-08-26)
+
## 0.18.0 - 2023-04-02
[0.17.0...0.18.0](https://github.com/rust-lang/git2-rs/compare/git2-curl-0.17.0...git2-curl-0.18.0)
diff --git a/vendor/git2-curl/Cargo.toml b/vendor/git2-curl/Cargo.toml
index e60ea6e63..16e5b3f0a 100644
--- a/vendor/git2-curl/Cargo.toml
+++ b/vendor/git2-curl/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "git2-curl"
-version = "0.18.0"
+version = "0.19.0"
authors = [
"Josh Triplett <josh@joshtriplett.org>",
"Alex Crichton <alex@alexcrichton.com>",
@@ -34,7 +34,7 @@ harness = false
version = "0.4.33"
[dependencies.git2]
-version = "0.17"
+version = "0.18"
default-features = false
[dependencies.log]
diff --git a/vendor/git2-curl/src/lib.rs b/vendor/git2-curl/src/lib.rs
index a0a6c9871..dbdbdc4a6 100644
--- a/vendor/git2-curl/src/lib.rs
+++ b/vendor/git2-curl/src/lib.rs
@@ -15,7 +15,7 @@
//! > **NOTE**: At this time this crate likely does not support a `git push`
//! > operation, only clones.
-#![doc(html_root_url = "https://docs.rs/git2-curl/0.18")]
+#![doc(html_root_url = "https://docs.rs/git2-curl/0.19")]
#![deny(missing_docs)]
#![warn(rust_2018_idioms)]
#![cfg_attr(test, deny(warnings))]