summaryrefslogtreecommitdiffstats
path: root/vendor/gix-commitgraph/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
commita0b8f38ab54ac451646aa00cd5e91b6c76f22a84 (patch)
treefc451898ccaf445814e26b46664d78702178101d /vendor/gix-commitgraph/Cargo.toml
parentAdding debian version 1.71.1+dfsg1-2. (diff)
downloadrustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.tar.xz
rustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/gix-commitgraph/Cargo.toml')
-rw-r--r--vendor/gix-commitgraph/Cargo.toml80
1 files changed, 80 insertions, 0 deletions
diff --git a/vendor/gix-commitgraph/Cargo.toml b/vendor/gix-commitgraph/Cargo.toml
new file mode 100644
index 000000000..d8b2e1090
--- /dev/null
+++ b/vendor/gix-commitgraph/Cargo.toml
@@ -0,0 +1,80 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-commitgraph"
+version = "0.16.0"
+authors = [
+ "Conor Davis <gitoxide@conor.fastmail.fm>",
+ "Sebastian Thiel <sebastian.thiel@icloud.com>",
+]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "CHANGELOG.md",
+]
+description = "Read-only access to the git commitgraph file format"
+documentation = "https://git-scm.com/docs/commit-graph#:~:text=The%20commit-graph%20file%20is%20a%20supplemental%20data%20structure,or%20in%20the%20info%20directory%20of%20an%20alternate."
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+doctest = false
+
+[dependencies.bstr]
+version = "1.3.0"
+features = ["std"]
+default-features = false
+
+[dependencies.document-features]
+version = "0.2.0"
+optional = true
+
+[dependencies.gix-chunk]
+version = "^0.4.2"
+
+[dependencies.gix-features]
+version = "^0.30.0"
+features = ["rustsha1"]
+
+[dependencies.gix-hash]
+version = "^0.11.2"
+
+[dependencies.memmap2]
+version = "0.5.0"
+
+[dependencies.serde]
+version = "1.0.114"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.thiserror]
+version = "1.0.26"
+
+[dev-dependencies]
+
+[features]
+serde = [
+ "dep:serde",
+ "gix-hash/serde",
+ "bstr/serde",
+]