summaryrefslogtreecommitdiffstats
path: root/vendor/gix-worktree
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:42 +0000
commitcec1877e180393eba0f6ddb0cf97bf3a791631c7 (patch)
tree47b4dac2a9dd9a40c30c251b4d4a72d7ccf77e9f /vendor/gix-worktree
parentAdding debian version 1.74.1+dfsg1-1. (diff)
downloadrustc-cec1877e180393eba0f6ddb0cf97bf3a791631c7.tar.xz
rustc-cec1877e180393eba0f6ddb0cf97bf3a791631c7.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/gix-worktree')
-rw-r--r--vendor/gix-worktree/.cargo-checksum.json2
-rw-r--r--vendor/gix-worktree/CHANGELOG.md35
-rw-r--r--vendor/gix-worktree/Cargo.toml18
-rw-r--r--vendor/gix-worktree/src/lib.rs1
-rw-r--r--vendor/gix-worktree/src/stack/delegate.rs18
-rw-r--r--vendor/gix-worktree/src/stack/mod.rs21
-rw-r--r--vendor/gix-worktree/src/stack/state/mod.rs5
7 files changed, 68 insertions, 32 deletions
diff --git a/vendor/gix-worktree/.cargo-checksum.json b/vendor/gix-worktree/.cargo-checksum.json
index 6f3364629..d05846bb1 100644
--- a/vendor/gix-worktree/.cargo-checksum.json
+++ b/vendor/gix-worktree/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"CHANGELOG.md":"3371d15a605196c4184b9f1091271e1dcbd15bacb24bdffaccf018f5036f9b04","Cargo.toml":"1627d1b359c58caa675f7098a8e2276d9f5563bfd36a5fa315ee7a0ec1ddacfe","LICENSE-APACHE":"cb4780590812826851ba250f90bed0ed19506ec98f6865a0e2e20bbf62391ff9","LICENSE-MIT":"49df47913ab2beafe8dc45607877ae64198bf0eee64aaad3e82ed9e4d27424e8","src/lib.rs":"05c141d039a666eb2c16fe9ca3169ea05eaa345dcb0e177760259b4af3442852","src/stack/delegate.rs":"62c099bf3cff362844b2306d8d3b2abdb7db5224c8975d8a19f77b62d81e49fb","src/stack/mod.rs":"31fcc73e73a7b39515422a6d057acd7d2fcba70301ee736041430eeb1d327b5f","src/stack/platform.rs":"08826af920e873d8495d844b57286428b79d954eda0acc05181b469e953b28ff","src/stack/state/attributes.rs":"4fb3aaa51bd60e2d38e86b901cead2d8085b2dc12866e2061a9ba37a5d36275c","src/stack/state/ignore.rs":"93affcabaf9bd0c23d047b7fbaca45a7bfa0522064c45127e07079a26f894c51","src/stack/state/mod.rs":"af9a438581392c6334f642b4fc4c8da5d76d691e4c7eeb7d5447504256369e60"},"package":"9f5e32972801bd82d56609e6fc84efc358fa1f11f25c5e83b7807ee2280f14fe"} \ No newline at end of file
+{"files":{"CHANGELOG.md":"633a8ec8c396a1fd07149c505048e6e59faaff85cecb2fab83e2f8794a3ff428","Cargo.toml":"af8df02f737cff9e04d2c6b60057dd2229361bd7d2cee70bbe4a8c96020d1707","LICENSE-APACHE":"cb4780590812826851ba250f90bed0ed19506ec98f6865a0e2e20bbf62391ff9","LICENSE-MIT":"49df47913ab2beafe8dc45607877ae64198bf0eee64aaad3e82ed9e4d27424e8","src/lib.rs":"7bbe788826dd799aeddc696f213a17a0976321c5f181e3d836f9e3b420470793","src/stack/delegate.rs":"b1e1ea27aa30b923b6b599be8e47c83ab4198fb838712e72133e3951680a1783","src/stack/mod.rs":"bbe0e26b204698384cece1c6548f10a8e5403920173b644e65e47e56904e391f","src/stack/platform.rs":"08826af920e873d8495d844b57286428b79d954eda0acc05181b469e953b28ff","src/stack/state/attributes.rs":"4fb3aaa51bd60e2d38e86b901cead2d8085b2dc12866e2061a9ba37a5d36275c","src/stack/state/ignore.rs":"93affcabaf9bd0c23d047b7fbaca45a7bfa0522064c45127e07079a26f894c51","src/stack/state/mod.rs":"00dd12c0032c75d6027af7549ecd144eee4134fa5a64b0d31f653192b7367e0e"},"package":"ddaf79e721dba64fe726a42f297a3c8ed42e55cdc0d81ca68452f2def3c2d7fd"} \ No newline at end of file
diff --git a/vendor/gix-worktree/CHANGELOG.md b/vendor/gix-worktree/CHANGELOG.md
index de794b02c..920422cb0 100644
--- a/vendor/gix-worktree/CHANGELOG.md
+++ b/vendor/gix-worktree/CHANGELOG.md
@@ -5,6 +5,38 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+## 0.27.0 (2023-10-12)
+
+### New Features (BREAKING)
+
+ - <csr-id-f1597756e5f6294f4757d90484f63e8d68bc05fa/> add `Stack::from_state_and_ignore_case()`.
+ It adds `Stack::from_state_and_ignore_case()` as utility to more easily instantiate
+ a stack the is configured correctly.
+ This also removes the `stack::State::for_status()` method as it's not actually
+ suitable for status retrieval per se.
+
+### Commit Statistics
+
+<csr-read-only-do-not-edit/>
+
+ - 4 commits contributed to the release over the course of 8 calendar days.
+ - 17 days passed between releases.
+ - 1 commit was understood as [conventional](https://www.conventionalcommits.org).
+ - 0 issues like '(#ID)' were seen in commit messages
+
+### Commit Details
+
+<csr-read-only-do-not-edit/>
+
+<details><summary>view details</summary>
+
+ * **Uncategorized**
+ - Release gix-hash v0.13.1, gix-features v0.36.0, gix-actor v0.28.0, gix-object v0.38.0, gix-glob v0.14.0, gix-attributes v0.20.0, gix-command v0.2.10, gix-filter v0.6.0, gix-fs v0.8.0, gix-commitgraph v0.22.0, gix-revwalk v0.9.0, gix-traverse v0.34.0, gix-worktree-stream v0.6.0, gix-archive v0.6.0, gix-tempfile v11.0.0, gix-lock v11.0.0, gix-ref v0.38.0, gix-config v0.31.0, gix-url v0.25.0, gix-credentials v0.21.0, gix-diff v0.37.0, gix-discover v0.26.0, gix-ignore v0.9.0, gix-index v0.26.0, gix-mailmap v0.20.0, gix-negotiate v0.9.0, gix-pack v0.44.0, gix-odb v0.54.0, gix-pathspec v0.4.0, gix-packetline v0.16.7, gix-transport v0.37.0, gix-protocol v0.41.0, gix-revision v0.23.0, gix-refspec v0.19.0, gix-worktree v0.27.0, gix-status v0.2.0, gix-submodule v0.5.0, gix-worktree-state v0.4.0, gix v0.55.0, safety bump 37 crates ([`68e5432`](https://github.com/Byron/gitoxide/commit/68e54326e527a55dd5b5079921fc251615833040))
+ - Prepare changelogs prior to release ([`1347a54`](https://github.com/Byron/gitoxide/commit/1347a54f84599d8f0aa935d6e64b16c2298d25cf))
+ - Merge branch 'reset' ([`b842691`](https://github.com/Byron/gitoxide/commit/b8426919a491dc3a7df01ee3f258fc0d8a3a327c))
+ - Add `Stack::from_state_and_ignore_case()`. ([`f159775`](https://github.com/Byron/gitoxide/commit/f1597756e5f6294f4757d90484f63e8d68bc05fa))
+</details>
+
## 0.26.0 (2023-09-24)
A maintenance release without user-facing changes.
@@ -13,7 +45,7 @@ A maintenance release without user-facing changes.
<csr-read-only-do-not-edit/>
- - 1 commit contributed to the release.
+ - 2 commits contributed to the release.
- 15 days passed between releases.
- 0 commits were understood as [conventional](https://www.conventionalcommits.org).
- 0 issues like '(#ID)' were seen in commit messages
@@ -25,6 +57,7 @@ A maintenance release without user-facing changes.
<details><summary>view details</summary>
* **Uncategorized**
+ - Release gix-features v0.35.0, gix-actor v0.27.0, gix-object v0.37.0, gix-glob v0.13.0, gix-attributes v0.19.0, gix-filter v0.5.0, gix-fs v0.7.0, gix-commitgraph v0.21.0, gix-revwalk v0.8.0, gix-traverse v0.33.0, gix-worktree-stream v0.5.0, gix-archive v0.5.0, gix-tempfile v10.0.0, gix-lock v10.0.0, gix-ref v0.37.0, gix-config v0.30.0, gix-url v0.24.0, gix-credentials v0.20.0, gix-diff v0.36.0, gix-discover v0.25.0, gix-ignore v0.8.0, gix-index v0.25.0, gix-mailmap v0.19.0, gix-negotiate v0.8.0, gix-pack v0.43.0, gix-odb v0.53.0, gix-pathspec v0.3.0, gix-transport v0.37.0, gix-protocol v0.40.0, gix-revision v0.22.0, gix-refspec v0.18.0, gix-status v0.1.0, gix-submodule v0.4.0, gix-worktree v0.26.0, gix-worktree-state v0.3.0, gix v0.54.0, gitoxide-core v0.32.0, gitoxide v0.30.0, safety bump 37 crates ([`7891fb1`](https://github.com/Byron/gitoxide/commit/7891fb17348ec2f4c997665f9a25be36e2713da4))
- Prepare changelogs prior to release ([`8a60d5b`](https://github.com/Byron/gitoxide/commit/8a60d5b80877c213c3b646d3061e8a33e0e433ec))
</details>
diff --git a/vendor/gix-worktree/Cargo.toml b/vendor/gix-worktree/Cargo.toml
index 5b8133ecf..74bfb3430 100644
--- a/vendor/gix-worktree/Cargo.toml
+++ b/vendor/gix-worktree/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.65"
name = "gix-worktree"
-version = "0.26.0"
+version = "0.27.0"
authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
include = [
"src/**/*",
@@ -47,29 +47,29 @@ version = "0.2.0"
optional = true
[dependencies.gix-attributes]
-version = "^0.19.0"
+version = "^0.20.0"
optional = true
[dependencies.gix-features]
-version = "^0.35.0"
+version = "^0.36.0"
[dependencies.gix-fs]
-version = "^0.7.0"
+version = "^0.8.0"
[dependencies.gix-glob]
-version = "^0.13.0"
+version = "^0.14.0"
[dependencies.gix-hash]
-version = "^0.13.0"
+version = "^0.13.1"
[dependencies.gix-ignore]
-version = "^0.8.0"
+version = "^0.9.0"
[dependencies.gix-index]
-version = "^0.25.0"
+version = "^0.26.0"
[dependencies.gix-object]
-version = "^0.37.0"
+version = "^0.38.0"
[dependencies.gix-path]
version = "^0.10.0"
diff --git a/vendor/gix-worktree/src/lib.rs b/vendor/gix-worktree/src/lib.rs
index 32d1d7c0e..b8e2e8974 100644
--- a/vendor/gix-worktree/src/lib.rs
+++ b/vendor/gix-worktree/src/lib.rs
@@ -10,6 +10,7 @@
#![cfg_attr(docsrs, feature(doc_cfg, doc_auto_cfg))]
#![deny(missing_docs, rust_2018_idioms, unsafe_code)]
use bstr::BString;
+pub use gix_glob;
/// A cache for efficiently executing operations on directories and files which are encountered in sorted order.
/// That way, these operations can be re-used for subsequent invocations in the same directory.
diff --git a/vendor/gix-worktree/src/stack/delegate.rs b/vendor/gix-worktree/src/stack/delegate.rs
index 28d8ecf34..8e48057de 100644
--- a/vendor/gix-worktree/src/stack/delegate.rs
+++ b/vendor/gix-worktree/src/stack/delegate.rs
@@ -56,7 +56,7 @@ impl<'a, 'find> gix_fs::stack::Delegate for StackDelegate<'a, 'find> {
};
match &mut self.state {
#[cfg(feature = "attributes")]
- State::CreateDirectoryAndAttributesStack { attributes, .. } => {
+ State::CreateDirectoryAndAttributesStack { attributes, .. } | State::AttributesStack(attributes) => {
attributes.push_directory(
stack.root(),
stack.current(),
@@ -89,16 +89,6 @@ impl<'a, 'find> gix_fs::stack::Delegate for StackDelegate<'a, 'find> {
&mut self.statistics.ignore,
)?
}
- #[cfg(feature = "attributes")]
- State::AttributesStack(attributes) => attributes.push_directory(
- stack.root(),
- stack.current(),
- rela_dir,
- self.buf,
- self.id_mappings,
- &mut self.find,
- &mut self.statistics.attributes,
- )?,
State::IgnoreStack(ignore) => ignore.push_directory(
stack.root(),
stack.current(),
@@ -139,7 +129,7 @@ impl<'a, 'find> gix_fs::stack::Delegate for StackDelegate<'a, 'find> {
self.statistics.delegate.pop_directory += 1;
match &mut self.state {
#[cfg(feature = "attributes")]
- State::CreateDirectoryAndAttributesStack { attributes, .. } => {
+ State::CreateDirectoryAndAttributesStack { attributes, .. } | State::AttributesStack(attributes) => {
attributes.pop_directory();
}
#[cfg(feature = "attributes")]
@@ -147,10 +137,6 @@ impl<'a, 'find> gix_fs::stack::Delegate for StackDelegate<'a, 'find> {
attributes.pop_directory();
ignore.pop_directory();
}
- #[cfg(feature = "attributes")]
- State::AttributesStack(attributes) => {
- attributes.pop_directory();
- }
State::IgnoreStack(ignore) => {
ignore.pop_directory();
}
diff --git a/vendor/gix-worktree/src/stack/mod.rs b/vendor/gix-worktree/src/stack/mod.rs
index c10320199..228467f5b 100644
--- a/vendor/gix-worktree/src/stack/mod.rs
+++ b/vendor/gix-worktree/src/stack/mod.rs
@@ -77,6 +77,27 @@ impl Stack {
statistics: Statistics::default(),
}
}
+
+ /// Create a new stack that takes into consideration the `ignore_case` result of a filesystem probe in `root`. It takes a configured
+ /// `state` to control what it can do, while initializing attribute or ignore files that are to be queried from the ODB using
+ /// `index` and `path_backing`.
+ ///
+ /// This is the easiest way to correctly setup a stack.
+ pub fn from_state_and_ignore_case(
+ root: impl Into<PathBuf>,
+ ignore_case: bool,
+ state: State,
+ index: &gix_index::State,
+ path_backing: &gix_index::PathStorageRef,
+ ) -> Self {
+ let case = if ignore_case {
+ gix_glob::pattern::Case::Fold
+ } else {
+ gix_glob::pattern::Case::Sensitive
+ };
+ let attribute_files = state.id_mappings_from_index(index, path_backing, case);
+ Stack::new(root, state, case, Vec::with_capacity(512), attribute_files)
+ }
}
/// Entry points for attribute query
diff --git a/vendor/gix-worktree/src/stack/state/mod.rs b/vendor/gix-worktree/src/stack/state/mod.rs
index 0b371425a..30e3c609f 100644
--- a/vendor/gix-worktree/src/stack/state/mod.rs
+++ b/vendor/gix-worktree/src/stack/state/mod.rs
@@ -71,11 +71,6 @@ impl State {
pub fn for_add(attributes: Attributes, ignore: Ignore) -> Self {
State::AttributesAndIgnoreStack { attributes, ignore }
}
-
- /// Configure a state for status retrieval, which needs access to ignore files only.
- pub fn for_status(ignore: Ignore) -> Self {
- State::IgnoreStack(ignore)
- }
}
/// Utilities