summaryrefslogtreecommitdiffstats
path: root/vendor/globset/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/globset/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/globset/Cargo.toml')
-rw-r--r--vendor/globset/Cargo.toml78
1 files changed, 78 insertions, 0 deletions
diff --git a/vendor/globset/Cargo.toml b/vendor/globset/Cargo.toml
new file mode 100644
index 000000000..4a52e0503
--- /dev/null
+++ b/vendor/globset/Cargo.toml
@@ -0,0 +1,78 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "globset"
+version = "0.4.9"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+description = """
+Cross platform single glob and glob set matching. Glob set matching is the
+process of matching one or more glob patterns against a single candidate path
+simultaneously, and returning all of the globs that matched.
+"""
+homepage = "https://github.com/BurntSushi/ripgrep/tree/master/crates/globset"
+documentation = "https://docs.rs/globset"
+readme = "README.md"
+keywords = [
+ "regex",
+ "glob",
+ "multiple",
+ "set",
+ "pattern",
+]
+license = "Unlicense OR MIT"
+repository = "https://github.com/BurntSushi/ripgrep/tree/master/crates/globset"
+
+[lib]
+name = "globset"
+bench = false
+
+[dependencies.aho-corasick]
+version = "0.7.3"
+
+[dependencies.bstr]
+version = "0.2.0"
+features = ["std"]
+default-features = false
+
+[dependencies.fnv]
+version = "1.0.6"
+
+[dependencies.log]
+version = "0.4.5"
+optional = true
+
+[dependencies.regex]
+version = "1.1.5"
+features = [
+ "perf",
+ "std",
+]
+default-features = false
+
+[dependencies.serde]
+version = "1.0.104"
+optional = true
+
+[dev-dependencies.glob]
+version = "0.3.0"
+
+[dev-dependencies.lazy_static]
+version = "1"
+
+[dev-dependencies.serde_json]
+version = "1.0.45"
+
+[features]
+default = ["log"]
+serde1 = ["serde"]
+simd-accel = []