summaryrefslogtreecommitdiffstats
path: root/vendor/globset/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/globset/README.md
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/globset/README.md')
-rw-r--r--vendor/globset/README.md8
1 files changed, 4 insertions, 4 deletions
diff --git a/vendor/globset/README.md b/vendor/globset/README.md
index 806c915b9..b7a4ebf6a 100644
--- a/vendor/globset/README.md
+++ b/vendor/globset/README.md
@@ -19,7 +19,7 @@ Add this to your `Cargo.toml`:
```toml
[dependencies]
-globset = "0.3"
+globset = "0.4"
```
### Features
@@ -78,12 +78,12 @@ assert_eq!(set.matches("src/bar/baz/foo.rs"), vec![0, 2]);
This crate implements globs by converting them to regular expressions, and
executing them with the
-[`regex`](https://github.com/rust-lang-nursery/regex)
+[`regex`](https://github.com/rust-lang/regex)
crate.
For single glob matching, performance of this crate should be roughly on par
with the performance of the
-[`glob`](https://github.com/rust-lang-nursery/glob)
+[`glob`](https://github.com/rust-lang/glob)
crate. (`*_regex` correspond to benchmarks for this library while `*_glob`
correspond to benchmarks for the `glob` library.)
Optimizations in the `regex` crate may propel this library past `glob`,
@@ -108,7 +108,7 @@ test many_short_glob ... bench: 1,063 ns/iter (+/- 47)
test many_short_regex_set ... bench: 186 ns/iter (+/- 11)
```
-### Comparison with the [`glob`](https://github.com/rust-lang-nursery/glob) crate
+### Comparison with the [`glob`](https://github.com/rust-lang/glob) crate
* Supports alternate "or" globs, e.g., `*.{foo,bar}`.
* Can match non-UTF-8 file paths correctly.