summaryrefslogtreecommitdiffstats
path: root/vendor/group/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/group/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/group/Cargo.toml')
-rw-r--r--vendor/group/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/vendor/group/Cargo.toml b/vendor/group/Cargo.toml
new file mode 100644
index 000000000..9bb4ce059
--- /dev/null
+++ b/vendor/group/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "group"
+version = "0.12.1"
+authors = ["Sean Bowe <ewillbefull@gmail.com>", "Jack Grigg <jack@z.cash>"]
+description = "Elliptic curve group traits and utilities"
+homepage = "https://github.com/zkcrypto/group"
+documentation = "https://docs.rs/group/"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/zkcrypto/group"
+resolver = "2"
+[dependencies.ff]
+version = "0.12"
+default-features = false
+
+[dependencies.memuse]
+version = "0.2"
+optional = true
+
+[dependencies.rand]
+version = "0.8"
+optional = true
+default-features = false
+
+[dependencies.rand_core]
+version = "0.6"
+default-features = false
+
+[dependencies.rand_xorshift]
+version = "0.3"
+optional = true
+
+[dependencies.subtle]
+version = "2.2.1"
+default-features = false
+
+[features]
+alloc = []
+default = ["alloc"]
+tests = ["alloc", "rand", "rand_xorshift"]
+wnaf-memuse = ["alloc", "memuse"]
+[badges.maintenance]
+status = "actively-developed"