summaryrefslogtreecommitdiffstats
path: root/vendor/hermit-abi-0.1.19
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/hermit-abi-0.1.19
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/hermit-abi-0.1.19')
-rw-r--r--vendor/hermit-abi-0.1.19/.cargo-checksum.json1
-rw-r--r--vendor/hermit-abi-0.1.19/Cargo.toml44
-rw-r--r--vendor/hermit-abi-0.1.19/LICENSE-APACHE201
-rw-r--r--vendor/hermit-abi-0.1.19/LICENSE-MIT23
-rw-r--r--vendor/hermit-abi-0.1.19/README.md22
-rw-r--r--vendor/hermit-abi-0.1.19/rust-toolchain1
-rw-r--r--vendor/hermit-abi-0.1.19/src/lib.rs490
-rw-r--r--vendor/hermit-abi-0.1.19/src/tcplistener.rs13
-rw-r--r--vendor/hermit-abi-0.1.19/src/tcpstream.rs109
9 files changed, 904 insertions, 0 deletions
diff --git a/vendor/hermit-abi-0.1.19/.cargo-checksum.json b/vendor/hermit-abi-0.1.19/.cargo-checksum.json
new file mode 100644
index 000000000..ea9987909
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"023c46a92caf2fc7a31fba3e7d4428a287e1fbdef822ed7e9a8f91284a30b387","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"322fadd63e558e5a10caf980cbedf83ac1546ba40fd992f54492e21ce54205af","rust-toolchain":"58bea07cb6d97f9cfcd5c8f98b1feca0fb81cce5b0bf29a8e70ed2641956e9a6","src/lib.rs":"c7dca30b651c91590ff46370bdaa10214062b9456395fb4bd549dedbf457c695","src/tcplistener.rs":"c6e2db06d4265fa0956851e1c965336d60c53ab21573729aae76ecfe0ccc84c3","src/tcpstream.rs":"38a17de54213faf9de217f6146ff86ee75b67d4404a532b1419903269200936b"},"package":"62b467343b94ba476dcb2500d242dadbb39557df889310ac77c5d99100aaac33"} \ No newline at end of file
diff --git a/vendor/hermit-abi-0.1.19/Cargo.toml b/vendor/hermit-abi-0.1.19/Cargo.toml
new file mode 100644
index 000000000..1f24268dd
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "hermit-abi"
+version = "0.1.19"
+authors = ["Stefan Lankes"]
+description = "hermit-abi is small interface to call functions from the unikernel RustyHermit.\nIt is used to build the target `x86_64-unknown-hermit`.\n"
+documentation = "https://hermitcore.github.io/rusty-hermit/hermit_abi"
+readme = "README.md"
+keywords = ["unikernel", "libos"]
+categories = ["os"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/hermitcore/libhermit-rs"
+[package.metadata.docs.rs]
+default-target = "x86_64-unknown-hermit"
+features = ["docs"]
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.libc]
+version = "0.2.51"
+default-features = false
+
+[features]
+default = []
+docs = []
+rustc-dep-of-std = ["core", "compiler_builtins/rustc-dep-of-std", "libc/rustc-dep-of-std"]
diff --git a/vendor/hermit-abi-0.1.19/LICENSE-APACHE b/vendor/hermit-abi-0.1.19/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/hermit-abi-0.1.19/LICENSE-MIT b/vendor/hermit-abi-0.1.19/LICENSE-MIT
new file mode 100644
index 000000000..31aa79387
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/hermit-abi-0.1.19/README.md b/vendor/hermit-abi-0.1.19/README.md
new file mode 100644
index 000000000..c75bfda0d
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/README.md
@@ -0,0 +1,22 @@
+# hermit-abi
+
+[![Crates.io](https://img.shields.io/crates/v/hermit-abi.svg)](https://crates.io/crates/hermit-abi)
+[![Documentation](https://img.shields.io/badge/docs-latest-blue.svg)](https://hermitcore.github.io/rusty-hermit/hermit_abi/)
+[![License](https://img.shields.io/crates/l/hermit-abi.svg)](https://img.shields.io/crates/l/hermit-abi.svg)
+
+This is small interface to call functions from the unikernel [RustyHermit](https://github.com/hermitcore/libhermit-rs).
+
+Please read the README of [RustyHermit](https://github.com/hermitcore/libhermit-rs) for more information.
+
+## License
+
+Licensed under either of
+
+* Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+* MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+## Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in the work by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any additional terms or conditions.
diff --git a/vendor/hermit-abi-0.1.19/rust-toolchain b/vendor/hermit-abi-0.1.19/rust-toolchain
new file mode 100644
index 000000000..bf867e0ae
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/rust-toolchain
@@ -0,0 +1 @@
+nightly
diff --git a/vendor/hermit-abi-0.1.19/src/lib.rs b/vendor/hermit-abi-0.1.19/src/lib.rs
new file mode 100644
index 000000000..9151faf56
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/src/lib.rs
@@ -0,0 +1,490 @@
+//! `hermit-abi` is small interface to call functions from the unikernel
+//! [RustyHermit](https://github.com/hermitcore/libhermit-rs).
+
+#![no_std]
+#![allow(clippy::missing_safety_doc)]
+#![allow(clippy::result_unit_err)]
+
+extern crate libc;
+
+pub mod tcplistener;
+pub mod tcpstream;
+
+use libc::c_void;
+
+// sysmbols, which are part of the library operating system
+
+extern "Rust" {
+ fn sys_secure_rand64() -> Option<u64>;
+ fn sys_secure_rand32() -> Option<u32>;
+}
+
+extern "C" {
+ fn sys_rand() -> u32;
+ fn sys_srand(seed: u32);
+ fn sys_get_processor_count() -> usize;
+ fn sys_malloc(size: usize, align: usize) -> *mut u8;
+ fn sys_realloc(ptr: *mut u8, size: usize, align: usize, new_size: usize) -> *mut u8;
+ fn sys_free(ptr: *mut u8, size: usize, align: usize);
+ fn sys_init_queue(ptr: usize) -> i32;
+ fn sys_notify(id: usize, count: i32) -> i32;
+ fn sys_add_queue(id: usize, timeout_ns: i64) -> i32;
+ fn sys_wait(id: usize) -> i32;
+ fn sys_destroy_queue(id: usize) -> i32;
+ fn sys_read(fd: i32, buf: *mut u8, len: usize) -> isize;
+ fn sys_write(fd: i32, buf: *const u8, len: usize) -> isize;
+ fn sys_close(fd: i32) -> i32;
+ fn sys_sem_init(sem: *mut *const c_void, value: u32) -> i32;
+ fn sys_sem_destroy(sem: *const c_void) -> i32;
+ fn sys_sem_post(sem: *const c_void) -> i32;
+ fn sys_sem_trywait(sem: *const c_void) -> i32;
+ fn sys_sem_timedwait(sem: *const c_void, ms: u32) -> i32;
+ fn sys_recmutex_init(recmutex: *mut *const c_void) -> i32;
+ fn sys_recmutex_destroy(recmutex: *const c_void) -> i32;
+ fn sys_recmutex_lock(recmutex: *const c_void) -> i32;
+ fn sys_recmutex_unlock(recmutex: *const c_void) -> i32;
+ fn sys_getpid() -> u32;
+ fn sys_exit(arg: i32) -> !;
+ fn sys_abort() -> !;
+ fn sys_usleep(usecs: u64);
+ fn sys_spawn(
+ id: *mut Tid,
+ func: extern "C" fn(usize),
+ arg: usize,
+ prio: u8,
+ core_id: isize,
+ ) -> i32;
+ fn sys_spawn2(
+ func: extern "C" fn(usize),
+ arg: usize,
+ prio: u8,
+ stack_size: usize,
+ core_id: isize,
+ ) -> Tid;
+ fn sys_join(id: Tid) -> i32;
+ fn sys_yield();
+ fn sys_clock_gettime(clock_id: u64, tp: *mut timespec) -> i32;
+ fn sys_open(name: *const i8, flags: i32, mode: i32) -> i32;
+ fn sys_unlink(name: *const i8) -> i32;
+ fn sys_network_init() -> i32;
+ fn sys_block_current_task();
+ fn sys_wakeup_task(tid: Tid);
+ fn sys_get_priority() -> u8;
+}
+
+/// A thread handle type
+pub type Tid = u32;
+
+/// Maximum number of priorities
+pub const NO_PRIORITIES: usize = 31;
+
+/// Priority of a thread
+#[derive(PartialEq, Eq, PartialOrd, Ord, Debug, Clone, Copy)]
+pub struct Priority(u8);
+
+impl Priority {
+ pub const fn into(self) -> u8 {
+ self.0
+ }
+
+ pub const fn from(x: u8) -> Self {
+ Priority(x)
+ }
+}
+
+pub const HIGH_PRIO: Priority = Priority::from(3);
+pub const NORMAL_PRIO: Priority = Priority::from(2);
+pub const LOW_PRIO: Priority = Priority::from(1);
+
+/// A handle, identifying a socket
+#[derive(Debug, Clone, Copy, PartialEq, Eq, PartialOrd, Ord, Default, Hash)]
+pub struct Handle(usize);
+
+pub const NSEC_PER_SEC: u64 = 1_000_000_000;
+pub const CLOCK_REALTIME: u64 = 1;
+pub const CLOCK_MONOTONIC: u64 = 4;
+pub const STDIN_FILENO: libc::c_int = 0;
+pub const STDOUT_FILENO: libc::c_int = 1;
+pub const STDERR_FILENO: libc::c_int = 2;
+pub const O_RDONLY: i32 = 0o0;
+pub const O_WRONLY: i32 = 0o1;
+pub const O_RDWR: i32 = 0o2;
+pub const O_CREAT: i32 = 0o100;
+pub const O_EXCL: i32 = 0o200;
+pub const O_TRUNC: i32 = 0o1000;
+pub const O_APPEND: i32 = 0o2000;
+
+/// returns true if file descriptor `fd` is a tty
+pub fn isatty(_fd: libc::c_int) -> bool {
+ false
+}
+
+/// intialize the network stack
+pub fn network_init() -> i32 {
+ unsafe { sys_network_init() }
+}
+
+/// `timespec` is used by `clock_gettime` to retrieve the
+/// current time
+#[derive(Copy, Clone, Debug)]
+#[repr(C)]
+pub struct timespec {
+ /// seconds
+ pub tv_sec: i64,
+ /// nanoseconds
+ pub tv_nsec: i64,
+}
+
+/// Internet protocol version.
+#[derive(Debug, Hash, PartialEq, Eq, PartialOrd, Ord, Clone, Copy)]
+pub enum Version {
+ Unspecified,
+ Ipv4,
+ Ipv6,
+}
+
+/// A four-octet IPv4 address.
+#[derive(Debug, Hash, PartialEq, Eq, PartialOrd, Ord, Clone, Copy, Default)]
+pub struct Ipv4Address(pub [u8; 4]);
+
+/// A sixteen-octet IPv6 address.
+#[derive(Debug, Hash, PartialEq, Eq, PartialOrd, Ord, Clone, Copy, Default)]
+pub struct Ipv6Address(pub [u8; 16]);
+
+/// An internetworking address.
+#[derive(Debug, Hash, PartialEq, Eq, PartialOrd, Ord, Clone, Copy)]
+pub enum IpAddress {
+ /// An unspecified address.
+ /// May be used as a placeholder for storage where the address is not assigned yet.
+ Unspecified,
+ /// An IPv4 address.
+ Ipv4(Ipv4Address),
+ /// An IPv6 address.
+ Ipv6(Ipv6Address),
+}
+
+/// determines the number of activated processors
+#[inline(always)]
+pub unsafe fn get_processor_count() -> usize {
+ sys_get_processor_count()
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn malloc(size: usize, align: usize) -> *mut u8 {
+ sys_malloc(size, align)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn realloc(ptr: *mut u8, size: usize, align: usize, new_size: usize) -> *mut u8 {
+ sys_realloc(ptr, size, align, new_size)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn free(ptr: *mut u8, size: usize, align: usize) {
+ sys_free(ptr, size, align)
+}
+
+#[inline(always)]
+pub unsafe fn notify(id: usize, count: i32) -> i32 {
+ sys_notify(id, count)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn add_queue(id: usize, timeout_ns: i64) -> i32 {
+ sys_add_queue(id, timeout_ns)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn wait(id: usize) -> i32 {
+ sys_wait(id)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn init_queue(id: usize) -> i32 {
+ sys_init_queue(id)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn destroy_queue(id: usize) -> i32 {
+ sys_destroy_queue(id)
+}
+
+/// read from a file descriptor
+///
+/// read() attempts to read `len` bytes of data from the object
+/// referenced by the descriptor `fd` into the buffer pointed
+/// to by `buf`.
+#[inline(always)]
+pub unsafe fn read(fd: i32, buf: *mut u8, len: usize) -> isize {
+ sys_read(fd, buf, len)
+}
+
+/// write to a file descriptor
+///
+/// write() attempts to write `len` of data to the object
+/// referenced by the descriptor `fd` from the
+/// buffer pointed to by `buf`.
+#[inline(always)]
+pub unsafe fn write(fd: i32, buf: *const u8, len: usize) -> isize {
+ sys_write(fd, buf, len)
+}
+
+/// close a file descriptor
+///
+/// The close() call deletes a file descriptor `fd` from the object
+/// reference table.
+#[inline(always)]
+pub unsafe fn close(fd: i32) -> i32 {
+ sys_close(fd)
+}
+
+/// sem_init() initializes the unnamed semaphore at the address
+/// pointed to by `sem`. The `value` argument specifies the
+/// initial value for the semaphore.
+#[inline(always)]
+pub unsafe fn sem_init(sem: *mut *const c_void, value: u32) -> i32 {
+ sys_sem_init(sem, value)
+}
+
+/// sem_destroy() frees the unnamed semaphore at the address
+/// pointed to by `sem`.
+#[inline(always)]
+pub unsafe fn sem_destroy(sem: *const c_void) -> i32 {
+ sys_sem_destroy(sem)
+}
+
+/// sem_post() increments the semaphore pointed to by `sem`.
+/// If the semaphore's value consequently becomes greater
+/// than zero, then another thread blocked in a sem_wait call
+/// will be woken up and proceed to lock the semaphore.
+#[inline(always)]
+pub unsafe fn sem_post(sem: *const c_void) -> i32 {
+ sys_sem_post(sem)
+}
+
+/// try to decrement a semaphore
+///
+/// sem_trywait() is the same as sem_timedwait(), except that
+/// if the decrement cannot be immediately performed, then call
+/// returns a negative value instead of blocking.
+#[inline(always)]
+pub unsafe fn sem_trywait(sem: *const c_void) -> i32 {
+ sys_sem_trywait(sem)
+}
+
+/// decrement a semaphore
+///
+/// sem_timedwait() decrements the semaphore pointed to by `sem`.
+/// If the semaphore's value is greater than zero, then the
+/// the function returns immediately. If the semaphore currently
+/// has the value zero, then the call blocks until either
+/// it becomes possible to perform the decrement of the time limit
+/// to wait for the semaphore is expired. A time limit `ms` of
+/// means infinity waiting time.
+#[inline(always)]
+pub unsafe fn sem_timedwait(sem: *const c_void, ms: u32) -> i32 {
+ sys_sem_timedwait(sem, ms)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn recmutex_init(recmutex: *mut *const c_void) -> i32 {
+ sys_recmutex_init(recmutex)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn recmutex_destroy(recmutex: *const c_void) -> i32 {
+ sys_recmutex_destroy(recmutex)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn recmutex_lock(recmutex: *const c_void) -> i32 {
+ sys_recmutex_lock(recmutex)
+}
+
+#[doc(hidden)]
+#[inline(always)]
+pub unsafe fn recmutex_unlock(recmutex: *const c_void) -> i32 {
+ sys_recmutex_unlock(recmutex)
+}
+
+/// Determines the id of the current thread
+#[inline(always)]
+pub unsafe fn getpid() -> u32 {
+ sys_getpid()
+}
+
+/// cause normal termination and return `arg`
+/// to the host system
+#[inline(always)]
+pub unsafe fn exit(arg: i32) -> ! {
+ sys_exit(arg)
+}
+
+/// cause abnormal termination
+#[inline(always)]
+pub unsafe fn abort() -> ! {
+ sys_abort()
+}
+
+/// suspend execution for microsecond intervals
+///
+/// The usleep() function suspends execution of the calling
+/// thread for (at least) `usecs` microseconds.
+#[inline(always)]
+pub unsafe fn usleep(usecs: u64) {
+ sys_usleep(usecs)
+}
+
+/// spawn a new thread
+///
+/// spawn() starts a new thread. The new thread starts execution
+/// by invoking `func(usize)`; `arg` is passed as the argument
+/// to `func`. `prio` defines the priority of the new thread,
+/// which can be between `LOW_PRIO` and `HIGH_PRIO`.
+/// `core_id` defines the core, where the thread is located.
+/// A negative value give the operating system the possibility
+/// to select the core by its own.
+#[inline(always)]
+pub unsafe fn spawn(
+ id: *mut Tid,
+ func: extern "C" fn(usize),
+ arg: usize,
+ prio: u8,
+ core_id: isize,
+) -> i32 {
+ sys_spawn(id, func, arg, prio, core_id)
+}
+
+/// spawn a new thread with user-specified stack size
+///
+/// spawn2() starts a new thread. The new thread starts execution
+/// by invoking `func(usize)`; `arg` is passed as the argument
+/// to `func`. `prio` defines the priority of the new thread,
+/// which can be between `LOW_PRIO` and `HIGH_PRIO`.
+/// `core_id` defines the core, where the thread is located.
+/// A negative value give the operating system the possibility
+/// to select the core by its own.
+/// In contrast to spawn(), spawn2() is able to define the
+/// stack size.
+#[inline(always)]
+pub unsafe fn spawn2(
+ func: extern "C" fn(usize),
+ arg: usize,
+ prio: u8,
+ stack_size: usize,
+ core_id: isize,
+) -> Tid {
+ sys_spawn2(func, arg, prio, stack_size, core_id)
+}
+
+/// join with a terminated thread
+///
+/// The join() function waits for the thread specified by `id`
+/// to terminate.
+#[inline(always)]
+pub unsafe fn join(id: Tid) -> i32 {
+ sys_join(id)
+}
+
+/// yield the processor
+///
+/// causes the calling thread to relinquish the CPU. The thread
+/// is moved to the end of the queue for its static priority.
+#[inline(always)]
+pub unsafe fn yield_now() {
+ sys_yield()
+}
+
+/// get current time
+///
+/// The clock_gettime() functions allow the calling thread
+/// to retrieve the value used by a clock which is specified
+/// by `clock_id`.
+///
+/// `CLOCK_REALTIME`: the system's real time clock,
+/// expressed as the amount of time since the Epoch.
+///
+/// `CLOCK_MONOTONIC`: clock that increments monotonically,
+/// tracking the time since an arbitrary point
+#[inline(always)]
+pub unsafe fn clock_gettime(clock_id: u64, tp: *mut timespec) -> i32 {
+ sys_clock_gettime(clock_id, tp)
+}
+
+/// open and possibly create a file
+///
+/// The open() system call opens the file specified by `name`.
+/// If the specified file does not exist, it may optionally
+/// be created by open().
+#[inline(always)]
+pub unsafe fn open(name: *const i8, flags: i32, mode: i32) -> i32 {
+ sys_open(name, flags, mode)
+}
+
+/// delete the file it refers to `name`
+#[inline(always)]
+pub unsafe fn unlink(name: *const i8) -> i32 {
+ sys_unlink(name)
+}
+
+/// The largest number `rand` will return
+pub const RAND_MAX: u64 = 2_147_483_647;
+
+/// The function computes a sequence of pseudo-random integers
+/// in the range of 0 to RAND_MAX
+#[inline(always)]
+pub unsafe fn rand() -> u32 {
+ sys_rand()
+}
+
+/// The function sets its argument as the seed for a new sequence
+/// of pseudo-random numbers to be returned by `rand`
+#[inline(always)]
+pub unsafe fn srand(seed: u32) {
+ sys_srand(seed);
+}
+
+/// Create a cryptographicly secure 32bit random number with the support of
+/// the underlying hardware. If the required hardware isn't available,
+/// the function returns `None`.
+#[inline(always)]
+pub unsafe fn secure_rand32() -> Option<u32> {
+ sys_secure_rand32()
+}
+
+/// Create a cryptographicly secure 64bit random number with the support of
+/// the underlying hardware. If the required hardware isn't available,
+/// the function returns `None`.
+#[inline(always)]
+pub unsafe fn secure_rand64() -> Option<u64> {
+ sys_secure_rand64()
+}
+
+/// Add current task to the queue of blocked tasl. After calling `block_current_task`,
+/// call `yield_now` to switch to another task.
+#[inline(always)]
+pub unsafe fn block_current_task() {
+ sys_block_current_task();
+}
+
+/// Wakeup task with the thread id `tid`
+#[inline(always)]
+pub unsafe fn wakeup_task(tid: Tid) {
+ sys_wakeup_task(tid);
+}
+
+/// Determine the priority of the current thread
+#[inline(always)]
+pub unsafe fn get_priority() -> Priority {
+ Priority::from(sys_get_priority())
+}
diff --git a/vendor/hermit-abi-0.1.19/src/tcplistener.rs b/vendor/hermit-abi-0.1.19/src/tcplistener.rs
new file mode 100644
index 000000000..5afe67364
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/src/tcplistener.rs
@@ -0,0 +1,13 @@
+//! `tcplistener` provide an interface to establish tcp socket server.
+
+use crate::{Handle, IpAddress};
+
+extern "Rust" {
+ fn sys_tcp_listener_accept(port: u16) -> Result<(Handle, IpAddress, u16), ()>;
+}
+
+/// Wait for connection at specified address.
+#[inline(always)]
+pub fn accept(port: u16) -> Result<(Handle, IpAddress, u16), ()> {
+ unsafe { sys_tcp_listener_accept(port) }
+}
diff --git a/vendor/hermit-abi-0.1.19/src/tcpstream.rs b/vendor/hermit-abi-0.1.19/src/tcpstream.rs
new file mode 100644
index 000000000..3024d379f
--- /dev/null
+++ b/vendor/hermit-abi-0.1.19/src/tcpstream.rs
@@ -0,0 +1,109 @@
+//! `tcpstream` provide an interface to establish tcp socket client.
+
+use crate::{Handle, IpAddress};
+
+extern "Rust" {
+ fn sys_tcp_stream_connect(ip: &[u8], port: u16, timeout: Option<u64>) -> Result<Handle, ()>;
+ fn sys_tcp_stream_close(handle: Handle) -> Result<(), ()>;
+ fn sys_tcp_stream_read(handle: Handle, buffer: &mut [u8]) -> Result<usize, ()>;
+ fn sys_tcp_stream_write(handle: Handle, buffer: &[u8]) -> Result<usize, ()>;
+ fn sys_tcp_stream_set_read_timeout(handle: Handle, timeout: Option<u64>) -> Result<(), ()>;
+ fn sys_tcp_stream_get_read_timeout(handle: Handle) -> Result<Option<u64>, ()>;
+ fn sys_tcp_stream_set_write_timeout(handle: Handle, timeout: Option<u64>) -> Result<(), ()>;
+ fn sys_tcp_stream_get_write_timeout(handle: Handle) -> Result<Option<u64>, ()>;
+ fn sys_tcp_stream_peek(handle: Handle, buf: &mut [u8]) -> Result<usize, ()>;
+ fn sys_tcp_stream_set_nonblocking(handle: Handle, mode: bool) -> Result<(), ()>;
+ fn sys_tcp_stream_set_tll(handle: Handle, ttl: u32) -> Result<(), ()>;
+ fn sys_tcp_stream_get_tll(handle: Handle) -> Result<u32, ()>;
+ fn sys_tcp_stream_shutdown(handle: Handle, how: i32) -> Result<(), ()>;
+ fn sys_tcp_stream_peer_addr(handle: Handle) -> Result<(IpAddress, u16), ()>;
+}
+
+/// Opens a TCP connection to a remote host.
+#[inline(always)]
+pub fn connect(ip: &[u8], port: u16, timeout: Option<u64>) -> Result<Handle, ()> {
+ unsafe { sys_tcp_stream_connect(ip, port, timeout) }
+}
+
+/// Close a TCP connection
+#[inline(always)]
+pub fn close(handle: Handle) -> Result<(), ()> {
+ unsafe { sys_tcp_stream_close(handle) }
+}
+
+#[inline(always)]
+pub fn peek(handle: Handle, buf: &mut [u8]) -> Result<usize, ()> {
+ unsafe { sys_tcp_stream_peek(handle, buf) }
+}
+
+#[inline(always)]
+pub fn peer_addr(handle: Handle) -> Result<(IpAddress, u16), ()> {
+ unsafe { sys_tcp_stream_peer_addr(handle) }
+}
+#[inline(always)]
+pub fn read(handle: Handle, buffer: &mut [u8]) -> Result<usize, ()> {
+ unsafe { sys_tcp_stream_read(handle, buffer) }
+}
+
+#[inline(always)]
+pub fn write(handle: Handle, buffer: &[u8]) -> Result<usize, ()> {
+ unsafe { sys_tcp_stream_write(handle, buffer) }
+}
+
+#[inline(always)]
+pub fn set_read_timeout(handle: Handle, timeout: Option<u64>) -> Result<(), ()> {
+ unsafe { sys_tcp_stream_set_read_timeout(handle, timeout) }
+}
+
+#[inline(always)]
+pub fn set_write_timeout(handle: Handle, timeout: Option<u64>) -> Result<(), ()> {
+ unsafe { sys_tcp_stream_set_write_timeout(handle, timeout) }
+}
+
+#[inline(always)]
+pub fn get_read_timeout(handle: Handle) -> Result<Option<u64>, ()> {
+ unsafe { sys_tcp_stream_get_read_timeout(handle) }
+}
+
+#[inline(always)]
+pub fn get_write_timeout(handle: Handle) -> Result<Option<u64>, ()> {
+ unsafe { sys_tcp_stream_get_write_timeout(handle) }
+}
+
+#[inline(always)]
+pub fn set_nodelay(_: Handle, mode: bool) -> Result<(), ()> {
+ // smoltcp does not support Nagle's algorithm
+ // => to enable Nagle's algorithm isn't possible
+ if mode {
+ Ok(())
+ } else {
+ Err(())
+ }
+}
+
+#[inline(always)]
+pub fn nodelay(_: Handle) -> Result<bool, ()> {
+ // smoltcp does not support Nagle's algorithm
+ // => return always true
+ Ok(true)
+}
+
+#[inline(always)]
+pub fn set_nonblocking(handle: Handle, mode: bool) -> Result<(), ()> {
+ unsafe { sys_tcp_stream_set_nonblocking(handle, mode) }
+}
+
+#[inline(always)]
+pub fn set_tll(handle: Handle, ttl: u32) -> Result<(), ()> {
+ unsafe { sys_tcp_stream_set_tll(handle, ttl) }
+}
+
+#[inline(always)]
+pub fn get_tll(handle: Handle) -> Result<u32, ()> {
+ unsafe { sys_tcp_stream_get_tll(handle) }
+}
+
+#[inline(always)]
+pub fn shutdown(handle: Handle, how: i32) -> Result<(), ()> {
+ unsafe { sys_tcp_stream_shutdown(handle, how) }
+}