summaryrefslogtreecommitdiffstats
path: root/vendor/html5ever/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/html5ever/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--vendor/html5ever/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/vendor/html5ever/Cargo.toml b/vendor/html5ever/Cargo.toml
new file mode 100644
index 000000000..d50b52243
--- /dev/null
+++ b/vendor/html5ever/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "html5ever"
+version = "0.26.0"
+authors = ["The html5ever Project Developers"]
+build = "build.rs"
+description = "High-performance browser-grade HTML5 parser"
+documentation = "https://docs.rs/html5ever"
+categories = ["parser-implementations", "web-programming"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/servo/html5ever"
+
+[[bench]]
+name = "html5ever"
+harness = false
+[dependencies.log]
+version = "0.4"
+
+[dependencies.mac]
+version = "0.1"
+
+[dependencies.markup5ever]
+version = "0.11"
+[dev-dependencies.typed-arena]
+version = "1.3.0"
+[build-dependencies.proc-macro2]
+version = "1"
+
+[build-dependencies.quote]
+version = "1"
+
+[build-dependencies.syn]
+version = "1"
+features = ["extra-traits", "full", "fold"]
+[target."cfg(bench)".dev-dependencies.criterion]
+version = "0.3"