summaryrefslogtreecommitdiffstats
path: root/vendor/iana-time-zone/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/iana-time-zone/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/iana-time-zone/Cargo.toml')
-rw-r--r--vendor/iana-time-zone/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/vendor/iana-time-zone/Cargo.toml b/vendor/iana-time-zone/Cargo.toml
new file mode 100644
index 000000000..5cdc175a7
--- /dev/null
+++ b/vendor/iana-time-zone/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "iana-time-zone"
+version = "0.1.56"
+authors = [
+ "Andrew Straw <strawman@astraw.com>",
+ "René Kijewski <rene.kijewski@fu-berlin.de>",
+ "Ryan Lopopolo <rjl@hyperbo.la>",
+]
+description = "get the IANA time zone for the current system"
+readme = "README.md"
+keywords = [
+ "IANA",
+ "time",
+]
+categories = [
+ "date-and-time",
+ "internationalization",
+ "os",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/strawlab/iana-time-zone"
+
+[features]
+fallback = []
+
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dependencies.core-foundation-sys]
+version = "0.8.3"
+
+[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
+version = "0.3.50"
+
+[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen]
+version = "0.2.70"
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
+version = "0.3"
+
+[target."cfg(target_os = \"android\")".dependencies.android_system_properties]
+version = "0.1.5"
+
+[target."cfg(target_os = \"haiku\")".dependencies.iana-time-zone-haiku]
+version = "0.1.1"
+
+[target."cfg(target_os = \"windows\")".dependencies.windows]
+version = "0.48.0"
+features = ["Globalization"]