summaryrefslogtreecommitdiffstats
path: root/vendor/if_chain
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/if_chain
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/if_chain')
-rw-r--r--vendor/if_chain/.cargo-checksum.json1
-rw-r--r--vendor/if_chain/CHANGELOG.md28
-rw-r--r--vendor/if_chain/Cargo.toml24
-rw-r--r--vendor/if_chain/LICENSE-APACHE201
-rw-r--r--vendor/if_chain/LICENSE-MIT25
-rw-r--r--vendor/if_chain/README.md9
-rw-r--r--vendor/if_chain/src/lib.rs314
7 files changed, 602 insertions, 0 deletions
diff --git a/vendor/if_chain/.cargo-checksum.json b/vendor/if_chain/.cargo-checksum.json
new file mode 100644
index 000000000..4d6d303e9
--- /dev/null
+++ b/vendor/if_chain/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"62692c9935114b66805a507216ddf4336235af325f941cc7c73579050dafed0d","Cargo.toml":"52ab2951a9de9d2bc5a7559a2a475f40f338b99eabcdbf8b4ffecb860b3d8d84","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"5de1878b4dbad85dc60131e58e6bca4503f7b141c2f7b2b295151568859c964a","README.md":"14131ede427018f56ea7f64d6fe09071af84c48480cfcda9c4f2ce44a1d99a3b","src/lib.rs":"462fc7b559f0c8481ef2eef351de786a836a5c6d95a5c80b049aedbe616d95da"},"package":"c3360c7b59e5ffa2653671fb74b4741a5d343c03f331c0a4aeda42b5c2b0ec7d"} \ No newline at end of file
diff --git a/vendor/if_chain/CHANGELOG.md b/vendor/if_chain/CHANGELOG.md
new file mode 100644
index 000000000..a49439b04
--- /dev/null
+++ b/vendor/if_chain/CHANGELOG.md
@@ -0,0 +1,28 @@
+# Changelog
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
+and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+
+## [Unreleased]
+
+## [1.0.0] - 2019-05-22
+### Changed
+- Update minimum Rust version to 1.12.0.
+
+### Fixed
+- Expand `if` and `if let` to their equivalent expressions instead of `match`.
+- Work around an edge case regarding Rust's treatment of `block` matchers.
+
+## [0.1.3] - 2018-07-20
+### Added
+- Add `local_inner_macros` attribute for compatibility with new-style macro imports.
+
+## [0.1.2] - 2017-02-17
+### Added
+- Support `no_std`.
+
+[Unreleased]: https://github.com/lfairy/if_chain/compare/v1.0.0...HEAD
+[1.0.0]: https://github.com/lfairy/if_chain/compare/v0.1.3...v1.0.0
+[0.1.3]: https://github.com/lfairy/if_chain/compare/v0.1.2...v0.1.3
+[0.1.2]: https://github.com/lfairy/if_chain/compare/v0.1.1...v0.1.2
diff --git a/vendor/if_chain/Cargo.toml b/vendor/if_chain/Cargo.toml
new file mode 100644
index 000000000..89381ed67
--- /dev/null
+++ b/vendor/if_chain/Cargo.toml
@@ -0,0 +1,24 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "if_chain"
+version = "1.0.0"
+authors = ["Chris Wong <lambda.fairy@gmail.com>"]
+description = "Macro for writing nested `if let` expressions."
+documentation = "https://docs.rs/if_chain"
+readme = "README.md"
+categories = ["rust-patterns", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/lfairy/if_chain"
+[badges.travis-ci]
+repository = "lfairy/if_chain"
diff --git a/vendor/if_chain/LICENSE-APACHE b/vendor/if_chain/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/if_chain/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/if_chain/LICENSE-MIT b/vendor/if_chain/LICENSE-MIT
new file mode 100644
index 000000000..6b2a21c01
--- /dev/null
+++ b/vendor/if_chain/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2018 Chris Wong
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/if_chain/README.md b/vendor/if_chain/README.md
new file mode 100644
index 000000000..23679ee04
--- /dev/null
+++ b/vendor/if_chain/README.md
@@ -0,0 +1,9 @@
+# if_chain
+
+[![Build Status](https://img.shields.io/travis/lfairy/if_chain.svg)](https://travis-ci.org/lfairy/if_chain) [![Cargo](https://img.shields.io/crates/v/if_chain.svg)](https://crates.io/crates/if_chain)
+
+This crate provides a single macro called `if_chain!`.
+
+`if_chain!` lets you write long chains of nested `if` and `if let` statements without the associated rightward drift. It also supports multiple patterns (e.g. `if let Foo(a) | Bar(a) = b`) in places where Rust would normally not allow them.
+
+For more information on this crate, see the [documentation](https://docs.rs/if_chain) and associated [blog post](https://lambda.xyz/blog/if-chain).
diff --git a/vendor/if_chain/src/lib.rs b/vendor/if_chain/src/lib.rs
new file mode 100644
index 000000000..e72f7aa88
--- /dev/null
+++ b/vendor/if_chain/src/lib.rs
@@ -0,0 +1,314 @@
+//! This crate provides a single macro called `if_chain!`.
+//!
+//! `if_chain!` lets you write long chains of nested `if` and `if let`
+//! statements without the associated rightward drift. It also supports multiple
+//! patterns (e.g. `if let Foo(a) | Bar(a) = b`) in places where Rust would
+//! normally not allow them.
+//!
+//! See the associated [blog post] for the background behind this crate.
+//!
+//! [blog post]: https://lambda.xyz/blog/if-chain
+//!
+//! # Note about recursion limits
+//!
+//! If you run into "recursion limit reached" errors while using this macro, try
+//! adding
+//!
+//! ```rust,ignore
+//! #![recursion_limit = "1000"]
+//! ```
+//!
+//! to the top of your crate.
+//!
+//! # Examples
+//!
+//! ## Quick start
+//!
+//! ```rust,ignore
+//! if_chain! {
+//! if let Some(y) = x;
+//! if y.len() == 2;
+//! if let Some(z) = y;
+//! then {
+//! do_stuff_with(z);
+//! }
+//! }
+//! ```
+//!
+//! becomes
+//!
+//! ```rust,ignore
+//! if let Some(y) = x {
+//! if y.len() == 2 {
+//! if let Some(z) = y {
+//! do_stuff_with(z);
+//! }
+//! }
+//! }
+//! ```
+//!
+//! ## Fallback values with `else`
+//!
+//! ```rust,ignore
+//! if_chain! {
+//! if let Some(y) = x;
+//! if let Some(z) = y;
+//! then {
+//! do_stuff_with(z)
+//! } else {
+//! do_something_else()
+//! }
+//! }
+//! ```
+//!
+//! becomes
+//!
+//! ```rust,ignore
+//! if let Some(y) = x {
+//! if let Some(z) = y {
+//! do_stuff_with(z)
+//! } else {
+//! do_something_else()
+//! }
+//! } else {
+//! do_something_else()
+//! }
+//! ```
+//!
+//! ## Intermediate variables with `let`
+//!
+//! ```rust,ignore
+//! if_chain! {
+//! if let Some(y) = x;
+//! let z = y.some().complicated().expression();
+//! if z == 42;
+//! then {
+//! do_stuff_with(y);
+//! }
+//! }
+//! ```
+//!
+//! becomes
+//!
+//! ```rust,ignore
+//! if let Some(y) = x {
+//! let z = y.some().complicated().expression();
+//! if z == 42 {
+//! do_stuff_with(y);
+//! }
+//! }
+//! ```
+//!
+//! ## Type ascription
+//!
+//! ```rust,ignore
+//! let mut x = some_generic_computation();
+//! if_chain! {
+//! if x > 7;
+//! let y: u32 = another_generic_computation();
+//! then { x += y }
+//! else { x += 1 }
+//! }
+//! ```
+//!
+//! becomes
+//!
+//! ```rust,ignore
+//! let mut x = some_generic_computation();
+//! if x > 7 {
+//! let y: u32 = another_generic_computation();
+//! x += y
+//! } else {
+//! x += 1
+//! }
+//! ```
+//!
+//! ## Multiple patterns
+//!
+//! ```rust,ignore
+//! if_chain! {
+//! if let Foo(y) | Bar(y) | Baz(y) = x;
+//! let Bubbles(z) | Buttercup(z) | Blossom(z) = y;
+//! then { do_stuff_with(z) }
+//! }
+//! ```
+//!
+//! becomes
+//!
+//! ```rust,ignore
+//! match x {
+//! Foo(y) | Bar(y) | Baz(y) => match y {
+//! Bubbles(z) | Buttercup(z) | Blossom(z) => do_stuff_with(z)
+//! },
+//! _ => {}
+//! }
+//! ```
+//!
+//! Note that if you use a plain `let`, then `if_chain!` assumes that the
+//! pattern is *irrefutable* (always matches) and doesn't add a fallback branch.
+
+#![cfg_attr(not(test), no_std)]
+
+/// Macro for writing nested `if let` expressions.
+///
+/// See the crate documentation for information on how to use this macro.
+#[macro_export(local_inner_macros)]
+macro_rules! if_chain {
+ ($($tt:tt)*) => {
+ __if_chain! { @init () $($tt)* }
+ };
+}
+
+#[doc(hidden)]
+#[macro_export(local_inner_macros)]
+macro_rules! __if_chain {
+ // Expand with both a successful case and a fallback
+ (@init ($($tt:tt)*) then { $($then:tt)* } else { $($other:tt)* }) => {
+ __if_chain! { @expand { $($other)* } $($tt)* then { $($then)* } }
+ };
+ // Expand with no fallback
+ (@init ($($tt:tt)*) then { $($then:tt)* }) => {
+ __if_chain! { @expand {} $($tt)* then { $($then)* } }
+ };
+ // Munch everything until either of the arms above can be matched.
+ // Munched tokens are placed into `$($tt)*`
+ (@init ($($tt:tt)*) $head:tt $($tail:tt)*) => {
+ __if_chain! { @init ($($tt)* $head) $($tail)* }
+ };
+
+ // `let` with a single pattern
+ (@expand { $($other:tt)* } let $pat:pat = $expr:expr; $($tt:tt)+) => {
+ {
+ let $pat = $expr;
+ __if_chain! { @expand { $($other)* } $($tt)+ }
+ }
+ };
+ // `let` with a single identifier and a type hint
+ (@expand { $($other:tt)* } let $ident:ident: $ty:ty = $expr:expr; $($tt:tt)+) => {
+ {
+ let $ident: $ty = $expr;
+ __if_chain! { @expand { $($other)* } $($tt)+ }
+ }
+ };
+ // `let` with multiple patterns
+ (@expand { $($other:tt)* } let $pat1:pat | $($pat:pat)|+ = $expr:expr; $($tt:tt)+) => {
+ match $expr {
+ $pat1 | $($pat)|+ => __if_chain! { @expand { $($other)* } $($tt)+ }
+ }
+ };
+ // `if let` with a single pattern
+ (@expand {} if let $pat:pat = $expr:expr; $($tt:tt)+) => {
+ if let $pat = $expr {
+ __if_chain! { @expand {} $($tt)+ }
+ }
+ };
+ // `if let` with a single pattern and a fallback
+ (@expand { $($other:tt)+ } if let $pat:pat = $expr:expr; $($tt:tt)+) => {
+ if let $pat = $expr {
+ __if_chain! { @expand { $($other)+ } $($tt)+ }
+ } else {
+ $($other)+
+ }
+ };
+ // `if let` with multiple matterns and a fallback (if present)
+ (@expand { $($other:tt)* } if let $pat1:pat | $($pat:pat)|+ = $expr:expr; $($tt:tt)+) => {
+ match $expr {
+ $pat1 | $($pat)|+ => { __if_chain! { @expand { $($other)* } $($tt)+ } },
+ _ => { $($other)* }
+ }
+ };
+ // `if` with a successful case
+ (@expand {} if $expr:expr; $($tt:tt)+) => {
+ if $expr {
+ __if_chain! { @expand {} $($tt)+ }
+ }
+ };
+ // `if` with both a successful case and a fallback
+ (@expand { $($other:tt)+ } if $expr:expr; $($tt:tt)+) => {
+ if $expr {
+ __if_chain! { @expand { $($other)+ } $($tt)+ }
+ } else {
+ $($other)+
+ }
+ };
+ // Final macro call
+ (@expand { $($other:tt)* } then { $($then:tt)* }) => {
+ $($then)*
+ };
+}
+
+#[cfg(test)]
+mod tests {
+ #[test]
+ fn simple() {
+ let x: Option<Result<Option<String>, (u32, u32)>> = Some(Err((41, 42)));
+ let mut success = false;
+ if_chain! {
+ if let Some(y) = x;
+ if let Err(z) = y;
+ let (_, b) = z;
+ if b == 42;
+ then { success = true; }
+ }
+ assert!(success);
+ }
+
+ #[test]
+ fn empty() {
+ let success;
+ if_chain! {
+ then { success = true; }
+ }
+ assert!(success);
+ }
+
+ #[test]
+ fn empty_with_else() {
+ let success;
+ if_chain! {
+ then { success = true; }
+ else { unreachable!(); }
+ }
+ assert!(success);
+ }
+
+ #[test]
+ fn if_let_multiple_patterns() {
+ #[derive(Copy, Clone)]
+ enum Robot { Nano, Biscuit1, Biscuit2 }
+ for &(robot, expected) in &[
+ (Robot::Nano, false),
+ (Robot::Biscuit1, true),
+ (Robot::Biscuit2, true),
+ ] {
+ let is_biscuit = if_chain! {
+ if let Robot::Biscuit1 | Robot::Biscuit2 = robot;
+ then { true } else { false }
+ };
+ assert_eq!(is_biscuit, expected);
+ }
+ }
+
+ #[test]
+ fn let_multiple_patterns() {
+ let x: Result<u32, u32> = Ok(42);
+ if_chain! {
+ let Ok(x) | Err(x) = x;
+ then { assert_eq!(x, 42); }
+ else { panic!(); }
+ }
+ }
+
+ #[test]
+ fn let_type_annotation_patterns() {
+ let mut x = 1;
+ if_chain! {
+ if x > 0;
+ let y: u32 = 2;
+
+ then { x += y; }
+ else { x += 1; }
+ };
+ assert_eq!(x, 3);
+ }
+}