summaryrefslogtreecommitdiffstats
path: root/vendor/instant/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/instant/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/instant/Cargo.toml')
-rw-r--r--vendor/instant/Cargo.toml81
1 files changed, 81 insertions, 0 deletions
diff --git a/vendor/instant/Cargo.toml b/vendor/instant/Cargo.toml
new file mode 100644
index 000000000..fcd0adff1
--- /dev/null
+++ b/vendor/instant/Cargo.toml
@@ -0,0 +1,81 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "instant"
+version = "0.1.12"
+authors = ["sebcrozet <developer@crozet.re>"]
+description = "A partial replacement for std::time::Instant that works on WASM too."
+readme = "README.md"
+keywords = ["time", "wasm"]
+license = "BSD-3-Clause"
+repository = "https://github.com/sebcrozet/instant"
+[dependencies.cfg-if]
+version = "1.0"
+[dev-dependencies.wasm-bindgen-test]
+version = "0.3"
+
+[features]
+inaccurate = []
+now = []
+wasm-bindgen = ["js-sys", "wasm-bindgen_rs", "web-sys"]
+[target.asmjs-unknown-emscripten.dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target.asmjs-unknown-emscripten.dependencies.stdweb]
+version = "0.4"
+optional = true
+
+[target.asmjs-unknown-emscripten.dependencies.wasm-bindgen_rs]
+version = "0.2"
+optional = true
+package = "wasm-bindgen"
+
+[target.asmjs-unknown-emscripten.dependencies.web-sys]
+version = "0.3"
+features = ["Window", "Performance", "PerformanceTiming"]
+optional = true
+[target.wasm32-unknown-emscripten.dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target.wasm32-unknown-emscripten.dependencies.stdweb]
+version = "0.4"
+optional = true
+
+[target.wasm32-unknown-emscripten.dependencies.wasm-bindgen_rs]
+version = "0.2"
+optional = true
+package = "wasm-bindgen"
+
+[target.wasm32-unknown-emscripten.dependencies.web-sys]
+version = "0.3"
+features = ["Window", "Performance", "PerformanceTiming"]
+optional = true
+[target.wasm32-unknown-unknown.dependencies.js-sys]
+version = "0.3"
+optional = true
+
+[target.wasm32-unknown-unknown.dependencies.stdweb]
+version = "0.4"
+optional = true
+
+[target.wasm32-unknown-unknown.dependencies.wasm-bindgen_rs]
+version = "0.2"
+optional = true
+package = "wasm-bindgen"
+
+[target.wasm32-unknown-unknown.dependencies.web-sys]
+version = "0.3"
+features = ["Window", "Performance", "PerformanceTiming"]
+optional = true