summaryrefslogtreecommitdiffstats
path: root/vendor/intl_pluralrules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
commit5363f350887b1e5b5dd21a86f88c8af9d7fea6da (patch)
tree35ca005eb6e0e9a1ba3bb5dbc033209ad445dc17 /vendor/intl_pluralrules
parentAdding debian version 1.66.0+dfsg1-1. (diff)
downloadrustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.tar.xz
rustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/intl_pluralrules')
-rw-r--r--vendor/intl_pluralrules/.cargo-checksum.json2
-rw-r--r--vendor/intl_pluralrules/Cargo.toml40
-rw-r--r--vendor/intl_pluralrules/README.md10
-rw-r--r--vendor/intl_pluralrules/src/lib.rs2
-rw-r--r--vendor/intl_pluralrules/src/operands.rs6
5 files changed, 38 insertions, 22 deletions
diff --git a/vendor/intl_pluralrules/.cargo-checksum.json b/vendor/intl_pluralrules/.cargo-checksum.json
index 58794afce..e72c5920d 100644
--- a/vendor/intl_pluralrules/.cargo-checksum.json
+++ b/vendor/intl_pluralrules/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"3b7451d96ed662827dd4163d64d96840fee1c4241c2480b8cdd91ef156ad7896","README.md":"4dad9bc033a67101bc318662c055318457f0b91e12fdc0a566495b455ceeb4b8","benches/pluralrules.rs":"9c80009fa94a8dbf31bdba489f320d92a40f482c37149030fbba53cd62b5435f","src/lib.rs":"a642fa4b7147731449acf39650fc92e764716de8303d9637c3263ae3ae03b899","src/operands.rs":"b58c9f8f0f7ce4622ccc685f08b15ede09591b628deffa3b14abde873d26c44a","src/rules.rs":"7b3f0c12e0722401efbdb54873e8545f943bf4a34cba9f894ead9dc955112aaf"},"package":"b18f988384267d7066cc2be425e6faf352900652c046b6971d2e228d3b1c5ecf"} \ No newline at end of file
+{"files":{"Cargo.toml":"595634ece6249e274c389db766170aa88f78df41e8887d333a7cac8dad6b0bed","README.md":"7516007e35aa847bf81b8b94f45181f532bdc0aad3e389efd14691fa3aace3f0","benches/pluralrules.rs":"9c80009fa94a8dbf31bdba489f320d92a40f482c37149030fbba53cd62b5435f","src/lib.rs":"054fd83f1e8b42ef7866ec681c59617952cad48f578ca338e945d2a99178ea7d","src/operands.rs":"68d920f66ed67f361b3b0387844dbb8db57fad660f84cfcb361d8f4f5157832a","src/rules.rs":"7b3f0c12e0722401efbdb54873e8545f943bf4a34cba9f894ead9dc955112aaf"},"package":"078ea7b7c29a2b4df841a7f6ac8775ff6074020c6776d48491ce2268e068f972"} \ No newline at end of file
diff --git a/vendor/intl_pluralrules/Cargo.toml b/vendor/intl_pluralrules/Cargo.toml
index 0dc0a943d..b5db6e609 100644
--- a/vendor/intl_pluralrules/Cargo.toml
+++ b/vendor/intl_pluralrules/Cargo.toml
@@ -3,40 +3,56 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "intl_pluralrules"
-version = "7.0.1"
-authors = ["Kekoa Riggin <kekoariggin@gmail.com>", "Zibi Braniecki <zbraniecki@mozilla.com>"]
-include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+version = "7.0.2"
+authors = [
+ "Kekoa Riggin <kekoariggin@gmail.com>",
+ "Zibi Braniecki <zbraniecki@mozilla.com>",
+]
+include = [
+ "src/**/*",
+ "benches/*.rs",
+ "Cargo.toml",
+ "README.md",
+]
description = "Unicode Plural Rules categorizer for numeric input."
readme = "README.md"
-keywords = ["localization", "l10n", "i18n", "intl", "internationalization"]
-categories = ["localization", "internationalization"]
+keywords = [
+ "localization",
+ "l10n",
+ "i18n",
+ "intl",
+ "internationalization",
+]
+categories = [
+ "localization",
+ "internationalization",
+]
license = "Apache-2.0/MIT"
repository = "https://github.com/zbraniecki/pluralrules"
[[bench]]
name = "pluralrules"
harness = false
-[dependencies.tinystr]
-version = "0.3.2"
[dependencies.unic-langid]
version = "0.9"
+
[dev-dependencies.criterion]
version = "0.3"
[dev-dependencies.unic-langid]
version = "0.9"
features = ["macros"]
+
[badges.coveralls]
branch = "master"
repository = "zbraniecki/pluralrules"
diff --git a/vendor/intl_pluralrules/README.md b/vendor/intl_pluralrules/README.md
index 6195142cd..50191d962 100644
--- a/vendor/intl_pluralrules/README.md
+++ b/vendor/intl_pluralrules/README.md
@@ -1,9 +1,9 @@
# INTL Plural Rules
-`intl_pluralrules` categorizes numbers by plural operands. See [Unicode Plural Rules](http://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules)
+`intl_pluralrules` categorizes numbers by plural operands. See [Unicode Plural Rules](https://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules)
-[![crates.io](http://meritbadge.herokuapp.com/intl_pluralrules)](https://crates.io/crates/intl_pluralrules)
+[![crates.io](https://img.shields.io/crates/v/intl_pluralrules.svg)](https://crates.io/crates/intl_pluralrules)
[![Build Status](https://travis-ci.org/zbraniecki/pluralrules.svg?branch=master)](https://travis-ci.org/zbraniecki/pluralrules)
[![Coverage Status](https://coveralls.io/repos/github/zbraniecki/pluralrules/badge.svg?branch=master)](https://coveralls.io/github/zbraniecki/pluralrules?branch=master)
@@ -37,6 +37,6 @@ Contributors
Thank you to all contributors!
-[CLDR]: http://cldr.unicode.org/
-[PluralRules]: http://cldr.unicode.org/index/cldr-spec/plural-rules
-[LDML Language Plural Rules Syntax]: http://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules
+[CLDR]: https://cldr.unicode.org/
+[PluralRules]: https://cldr.unicode.org/index/cldr-spec/plural-rules
+[LDML Language Plural Rules Syntax]: https://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules
diff --git a/vendor/intl_pluralrules/src/lib.rs b/vendor/intl_pluralrules/src/lib.rs
index 8e577dfeb..84a2fd635 100644
--- a/vendor/intl_pluralrules/src/lib.rs
+++ b/vendor/intl_pluralrules/src/lib.rs
@@ -1,6 +1,6 @@
//! A crate for generating plural rule operands from numberical input.
//!
-//! This crate generates plural operands according to the specifications outlined at [Unicode's website](http://unicode.org/reports/tr35/tr35-numbers.html#Operands).
+//! This crate generates plural operands according to the specifications outlined at [Unicode's website](https://unicode.org/reports/tr35/tr35-numbers.html#Operands).
//!
//! Input is supported for int, float, and &str.
//!
diff --git a/vendor/intl_pluralrules/src/operands.rs b/vendor/intl_pluralrules/src/operands.rs
index 78fa80aff..102ae8742 100644
--- a/vendor/intl_pluralrules/src/operands.rs
+++ b/vendor/intl_pluralrules/src/operands.rs
@@ -1,6 +1,6 @@
-//! Plural operands in compliance with [CLDR Plural Rules](http://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules).
+//! Plural operands in compliance with [CLDR Plural Rules](https://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules).
//!
-//! See [full operands description](http://unicode.org/reports/tr35/tr35-numbers.html#Operands).
+//! See [full operands description](https://unicode.org/reports/tr35/tr35-numbers.html#Operands).
//!
//! # Examples
//!
@@ -53,7 +53,7 @@ use std::convert::TryFrom;
use std::isize;
use std::str::FromStr;
-/// A full plural operands representation of a number. See [CLDR Plural Rules](http://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules) for complete operands description.
+/// A full plural operands representation of a number. See [CLDR Plural Rules](https://unicode.org/reports/tr35/tr35-numbers.html#Language_Plural_Rules) for complete operands description.
#[derive(Debug, PartialEq)]
pub struct PluralOperands {
/// Absolute value of input