summaryrefslogtreecommitdiffstats
path: root/vendor/libloading/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/libloading/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libloading/Cargo.toml')
-rw-r--r--vendor/libloading/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/vendor/libloading/Cargo.toml b/vendor/libloading/Cargo.toml
new file mode 100644
index 000000000..39b41f3e4
--- /dev/null
+++ b/vendor/libloading/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+rust-version = "1.40.0"
+name = "libloading"
+version = "0.7.3"
+authors = ["Simonas Kazlauskas <libloading@kazlauskas.me>"]
+description = "Bindings around the platform's dynamic library loading primitives with greatly improved memory safety."
+documentation = "https://docs.rs/libloading/"
+readme = "README.mkd"
+keywords = ["dlopen", "load", "shared", "dylib"]
+categories = ["api-bindings"]
+license = "ISC"
+repository = "https://github.com/nagisa/rust_libloading/"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "libloading_docs"]
+[dev-dependencies.libc]
+version = "0.2"
+
+[dev-dependencies.static_assertions]
+version = "1.1"
+[target."cfg(unix)".dependencies.cfg-if]
+version = "1"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["errhandlingapi", "libloaderapi"]