summaryrefslogtreecommitdiffstats
path: root/vendor/link-cplusplus
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/link-cplusplus
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/link-cplusplus')
-rw-r--r--vendor/link-cplusplus/.cargo-checksum.json1
-rw-r--r--vendor/link-cplusplus/Cargo.toml47
-rw-r--r--vendor/link-cplusplus/LICENSE-APACHE201
-rw-r--r--vendor/link-cplusplus/LICENSE-MIT23
-rw-r--r--vendor/link-cplusplus/README.md79
-rw-r--r--vendor/link-cplusplus/build.rs34
-rw-r--r--vendor/link-cplusplus/src/lib.rs66
7 files changed, 451 insertions, 0 deletions
diff --git a/vendor/link-cplusplus/.cargo-checksum.json b/vendor/link-cplusplus/.cargo-checksum.json
new file mode 100644
index 000000000..df51634ef
--- /dev/null
+++ b/vendor/link-cplusplus/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"7438c776066def5b8e11509c23054bacbdc032fcc107298acefa30c2333ecabb","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"36d250081a7e761f54040a793bda9e77428d30f64ed55d6881aed07946ce9859","build.rs":"fde8d74a3a28071cb063c104aacb3c0157261641adcd4975eb0ef9d58ec552b1","src/lib.rs":"efd02a72c3937172ed3cf8eb3c1ab31bb25dc0e32e3b24cfececea5320d4d7c3"},"package":"ecd207c9c713c34f95a097a5b029ac2ce6010530c7b49d7fea24d977dede04f5"} \ No newline at end of file
diff --git a/vendor/link-cplusplus/Cargo.toml b/vendor/link-cplusplus/Cargo.toml
new file mode 100644
index 000000000..84c8c3886
--- /dev/null
+++ b/vendor/link-cplusplus/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.34"
+name = "link-cplusplus"
+version = "1.0.8"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+links = "cplusplus"
+description = "Link libstdc++ or libc++ automatically or manually"
+documentation = "https://docs.rs/link-cplusplus"
+readme = "README.md"
+keywords = [
+ "linkage",
+ "c++",
+]
+categories = [
+ "external-ffi-bindings",
+ "development-tools::ffi",
+ "compilers",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/link-cplusplus"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[build-dependencies.cc]
+version = "1.0"
+
+[features]
+default = []
+"libc++" = []
+libcxx = ["libc++"]
+"libstdc++" = []
+libstdcxx = ["libstdc++"]
+nothing = []
diff --git a/vendor/link-cplusplus/LICENSE-APACHE b/vendor/link-cplusplus/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/link-cplusplus/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/link-cplusplus/LICENSE-MIT b/vendor/link-cplusplus/LICENSE-MIT
new file mode 100644
index 000000000..31aa79387
--- /dev/null
+++ b/vendor/link-cplusplus/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/link-cplusplus/README.md b/vendor/link-cplusplus/README.md
new file mode 100644
index 000000000..7743b4f3b
--- /dev/null
+++ b/vendor/link-cplusplus/README.md
@@ -0,0 +1,79 @@
+`-lstdc++` or `-lc++`
+=====================
+
+[<img alt="github" src="https://img.shields.io/badge/github-dtolnay/link--cplusplus-8da0cb?style=for-the-badge&labelColor=555555&logo=github" height="20">](https://github.com/dtolnay/link-cplusplus)
+[<img alt="crates.io" src="https://img.shields.io/crates/v/link-cplusplus.svg?style=for-the-badge&color=fc8d62&logo=rust" height="20">](https://crates.io/crates/link-cplusplus)
+[<img alt="docs.rs" src="https://img.shields.io/badge/docs.rs-link--cplusplus-66c2a5?style=for-the-badge&labelColor=555555&logo=docs.rs" height="20">](https://docs.rs/link-cplusplus)
+[<img alt="build status" src="https://img.shields.io/github/actions/workflow/status/dtolnay/link-cplusplus/ci.yml?branch=master&style=for-the-badge" height="20">](https://github.com/dtolnay/link-cplusplus/actions?query=branch%3Amaster)
+
+This crate exists for the purpose of passing `-lstdc++` or `-lc++` to the
+linker, while making it possible for an application to make that choice on
+behalf of its library dependencies.
+
+Without this crate, a library would need to:
+
+- pick one or the other to link, with no way for downstream applications to
+ override the choice;
+- or link neither and require an explicit link flag provided by downstream
+ applications even if they would be fine with a default choice;
+
+neither of which are good experiences.
+
+<br>
+
+## Options
+
+An application or library that is fine with either of libstdc++ or libc++ being
+linked, whichever is the platform's default, should use the following in
+Cargo.toml:
+
+```toml
+[dependencies]
+link-cplusplus = "1.0"
+```
+
+An application that wants a particular one or the other linked should use:
+
+```toml
+[dependencies]
+link-cplusplus = { version = "1.0", features = ["libstdc++"] }
+
+# or
+
+link-cplusplus = { version = "1.0", features = ["libc++"] }
+```
+
+An application that wants to handle its own more complicated logic for link
+flags from its build script can make this crate do nothing by using:
+
+```toml
+[dependencies]
+link-cplusplus = { version = "1.0", features = ["nothing"] }
+```
+
+Lastly, make sure to add an explicit `extern crate` dependency to your crate
+root, since the link-cplusplus crate will be otherwise unused and its link flags
+dropped.
+
+```rust
+// src/lib.rs
+
+extern crate link_cplusplus;
+```
+
+<br>
+
+#### License
+
+<sup>
+Licensed under either of <a href="LICENSE-APACHE">Apache License, Version
+2.0</a> or <a href="LICENSE-MIT">MIT license</a> at your option.
+</sup>
+
+<br>
+
+<sub>
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in this project by you, as defined in the Apache-2.0 license,
+shall be dual licensed as above, without any additional terms or conditions.
+</sub>
diff --git a/vendor/link-cplusplus/build.rs b/vendor/link-cplusplus/build.rs
new file mode 100644
index 000000000..1f679229e
--- /dev/null
+++ b/vendor/link-cplusplus/build.rs
@@ -0,0 +1,34 @@
+use std::env;
+use std::fs;
+use std::path::PathBuf;
+
+fn main() {
+ println!("cargo:rerun-if-changed=build.rs");
+
+ let libstdcxx = cfg!(feature = "libstdc++");
+ let libcxx = cfg!(feature = "libc++");
+ let nothing = cfg!(feature = "nothing");
+
+ if nothing {
+ return;
+ }
+
+ if libstdcxx && libcxx {
+ println!(
+ "cargo:warning=-lstdc++ and -lc++ are both requested, \
+ using the platform's default"
+ );
+ }
+
+ match (libstdcxx, libcxx) {
+ (true, false) => println!("cargo:rustc-link-lib=stdc++"),
+ (false, true) => println!("cargo:rustc-link-lib=c++"),
+ (false, false) | (true, true) => {
+ // The platform's default.
+ let out_dir = env::var_os("OUT_DIR").expect("missing OUT_DIR");
+ let path = PathBuf::from(out_dir).join("dummy.cc");
+ fs::write(&path, "int rust_link_cplusplus;\n").unwrap();
+ cc::Build::new().cpp(true).file(&path).compile("link-cplusplus");
+ }
+ }
+}
diff --git a/vendor/link-cplusplus/src/lib.rs b/vendor/link-cplusplus/src/lib.rs
new file mode 100644
index 000000000..7864d5974
--- /dev/null
+++ b/vendor/link-cplusplus/src/lib.rs
@@ -0,0 +1,66 @@
+//! [![github]](https://github.com/dtolnay/link-cplusplus)&ensp;[![crates-io]](https://crates.io/crates/link-cplusplus)&ensp;[![docs-rs]](https://docs.rs/link-cplusplus)
+//!
+//! [github]: https://img.shields.io/badge/github-8da0cb?style=for-the-badge&labelColor=555555&logo=github
+//! [crates-io]: https://img.shields.io/badge/crates.io-fc8d62?style=for-the-badge&labelColor=555555&logo=rust
+//! [docs-rs]: https://img.shields.io/badge/docs.rs-66c2a5?style=for-the-badge&labelColor=555555&logo=docs.rs
+//!
+//! <br>
+//!
+//! # `-lstdc++` or `-lc++`
+//!
+//! This crate exists for the purpose of passing `-lstdc++` or `-lc++` to the
+//! linker, while making it possible for an application to make that choice on
+//! behalf of its library dependencies.
+//!
+//! Without this crate, a library would need to:
+//!
+//! - pick one or the other to link, with no way for downstream applications to
+//! override the choice;
+//! - or link neither and require an explicit link flag provided by downstream
+//! applications even if they would be fine with a default choice;
+//!
+//! neither of which are good experiences.
+//!
+//! <br>
+//!
+//! # Options
+//!
+//! An application or library that is fine with either of libstdc++ or libc++
+//! being linked, whichever is the platform's default, should use the following
+//! in Cargo.toml:
+//!
+//! ```toml
+//! [dependencies]
+//! link-cplusplus = "1.0"
+//! ```
+//!
+//! An application that wants a particular one or the other linked should use:
+//!
+//! ```toml
+//! [dependencies]
+//! link-cplusplus = { version = "1.0", features = ["libstdc++"] }
+//!
+//! # or
+//!
+//! link-cplusplus = { version = "1.0", features = ["libc++"] }
+//! ```
+//!
+//! An application that wants to handle its own more complicated logic for link
+//! flags from its build script can make this crate do nothing by using:
+//!
+//! ```toml
+//! [dependencies]
+//! link-cplusplus = { version = "1.0", features = ["nothing"] }
+//! ```
+//!
+//! Lastly, make sure to add an explicit `extern crate` dependency to your crate
+//! root, since the link-cplusplus crate will be otherwise unused and its link
+//! flags dropped.
+//!
+//! ```
+//! // src/lib.rs
+//!
+//! extern crate link_cplusplus;
+//! ```
+
+#![no_std]