summaryrefslogtreecommitdiffstats
path: root/vendor/linux-raw-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/linux-raw-sys/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/linux-raw-sys/Cargo.toml')
-rw-r--r--vendor/linux-raw-sys/Cargo.toml74
1 files changed, 74 insertions, 0 deletions
diff --git a/vendor/linux-raw-sys/Cargo.toml b/vendor/linux-raw-sys/Cargo.toml
new file mode 100644
index 000000000..3f1463eed
--- /dev/null
+++ b/vendor/linux-raw-sys/Cargo.toml
@@ -0,0 +1,74 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "linux-raw-sys"
+version = "0.0.46"
+authors = ["Dan Gohman <dev@sunfishcode.online>"]
+exclude = [
+ "/gen",
+ "/.*",
+]
+description = "Generated bindings for Linux's userspace API"
+documentation = "https://docs.rs/linux-raw-sys"
+keywords = [
+ "linux",
+ "uapi",
+ "ffi",
+]
+categories = ["external-ffi-bindings"]
+license = "Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT"
+repository = "https://github.com/sunfishcode/linux-raw-sys"
+
+[package.metadata.docs.rs]
+features = [
+ "default",
+ "ioctl",
+ "netlink",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "i686-unknown-linux-gnu",
+]
+
+[dependencies.compiler_builtins]
+version = "0.1.49"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dev-dependencies.libc]
+version = "0.2.100"
+
+[dev-dependencies.static_assertions]
+version = "1.1.0"
+
+[features]
+default = [
+ "std",
+ "general",
+ "errno",
+]
+errno = []
+general = []
+ioctl = []
+netlink = []
+no_std = []
+rustc-dep-of-std = [
+ "core",
+ "compiler_builtins",
+ "no_std",
+]
+std = []