summaryrefslogtreecommitdiffstats
path: root/vendor/md-5/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
commita0b8f38ab54ac451646aa00cd5e91b6c76f22a84 (patch)
treefc451898ccaf445814e26b46664d78702178101d /vendor/md-5/Cargo.toml
parentAdding debian version 1.71.1+dfsg1-2. (diff)
downloadrustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.tar.xz
rustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/md-5/Cargo.toml')
-rw-r--r--vendor/md-5/Cargo.toml29
1 files changed, 20 insertions, 9 deletions
diff --git a/vendor/md-5/Cargo.toml b/vendor/md-5/Cargo.toml
index b65ecf0ec..fddb804ce 100644
--- a/vendor/md-5/Cargo.toml
+++ b/vendor/md-5/Cargo.toml
@@ -12,32 +12,43 @@
[package]
edition = "2018"
name = "md-5"
-version = "0.10.0"
+version = "0.10.5"
authors = ["RustCrypto Developers"]
description = "MD5 hash function"
documentation = "https://docs.rs/md-5"
readme = "README.md"
-keywords = ["crypto", "md5", "hash", "digest"]
-categories = ["cryptography", "no-std"]
+keywords = [
+ "crypto",
+ "md5",
+ "hash",
+ "digest",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/RustCrypto/hashes"
[lib]
name = "md5"
+
[dependencies.digest]
-version = "0.10"
+version = "0.10.4"
-[dependencies.md5-asm]
-version = "0.5"
-optional = true
[dev-dependencies.digest]
-version = "0.10"
+version = "0.10.4"
features = ["dev"]
[dev-dependencies.hex-literal]
-version = "0.2"
+version = "0.2.2"
[features]
asm = ["md5-asm"]
default = ["std"]
+oid = ["digest/oid"]
std = ["digest/std"]
+
+[target."cfg(any(target_arch = \"x86\", target_arch = \"x86_64\"))".dependencies.md5-asm]
+version = "0.5"
+optional = true