summaryrefslogtreecommitdiffstats
path: root/vendor/mime_guess/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /vendor/mime_guess/Cargo.toml
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/mime_guess/Cargo.toml')
-rw-r--r--vendor/mime_guess/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/vendor/mime_guess/Cargo.toml b/vendor/mime_guess/Cargo.toml
new file mode 100644
index 000000000..fc6f68d2a
--- /dev/null
+++ b/vendor/mime_guess/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "mime_guess"
+version = "2.0.4"
+authors = ["Austin Bonander <austin.bonander@gmail.com>"]
+description = "A simple crate for detection of a file's MIME type by its extension."
+documentation = "https://docs.rs/mime_guess/"
+readme = "README.md"
+keywords = ["mime", "filesystem", "extension"]
+license = "MIT"
+repository = "https://github.com/abonander/mime_guess"
+
+[[example]]
+name = "rev_map"
+required-features = ["rev-mappings"]
+
+[[bench]]
+name = "benchmark"
+harness = false
+[dependencies.mime]
+version = "0.3"
+
+[dependencies.unicase]
+version = "2.4.0"
+[dev-dependencies.criterion]
+version = "0.3"
+[build-dependencies.unicase]
+version = "2.4.0"
+
+[features]
+default = ["rev-mappings"]
+rev-mappings = []