summaryrefslogtreecommitdiffstats
path: root/vendor/miow/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/miow/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/miow/Cargo.toml')
-rw-r--r--vendor/miow/Cargo.toml58
1 files changed, 0 insertions, 58 deletions
diff --git a/vendor/miow/Cargo.toml b/vendor/miow/Cargo.toml
deleted file mode 100644
index 2538f4b19..000000000
--- a/vendor/miow/Cargo.toml
+++ /dev/null
@@ -1,58 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "miow"
-version = "0.5.0"
-authors = ["Alex Crichton <alex@alexcrichton.com>"]
-description = """
-A zero overhead I/O library for Windows, focusing on IOCP and async I/O
-abstractions.
-"""
-homepage = "https://github.com/yoshuawuyts/miow"
-documentation = "https://docs.rs/miow"
-readme = "README.md"
-keywords = [
- "iocp",
- "windows",
- "io",
- "overlapped",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/yoshuawuyts/miow"
-
-[package.metadata.docs.rs]
-default-target = "x86_64-pc-windows-msvc"
-targets = [
- "aarch64-pc-windows-msvc",
- "i686-pc-windows-msvc",
- "x86_64-pc-windows-msvc",
-]
-
-[dependencies.windows-sys]
-version = "0.42.0"
-features = [
- "Win32_Foundation",
- "Win32_Networking_WinSock",
- "Win32_Security",
- "Win32_Storage_FileSystem",
- "Win32_System_IO",
- "Win32_System_Pipes",
- "Win32_System_Threading",
- "Win32_System_WindowsProgramming",
-]
-
-[dev-dependencies.rand]
-version = "0.8.0"
-
-[dev-dependencies.socket2]
-version = "0.4.0"