summaryrefslogtreecommitdiffstats
path: root/vendor/nom/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/nom/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/nom/Cargo.toml')
-rw-r--r--vendor/nom/Cargo.toml130
1 files changed, 130 insertions, 0 deletions
diff --git a/vendor/nom/Cargo.toml b/vendor/nom/Cargo.toml
new file mode 100644
index 000000000..6e38fa0db
--- /dev/null
+++ b/vendor/nom/Cargo.toml
@@ -0,0 +1,130 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "nom"
+version = "7.1.0"
+authors = ["contact@geoffroycouprie.com"]
+include = ["CHANGELOG.md", "LICENSE", "README.md", ".gitignore", "Cargo.toml", "src/*.rs", "src/*/*.rs", "tests/*.rs", "doc/nom_recipes.md", "build.rs"]
+autoexamples = false
+description = "A byte-oriented, zero-copy, parser combinators library"
+documentation = "https://docs.rs/nom"
+readme = "README.md"
+keywords = ["parser", "parser-combinators", "parsing", "streaming", "bit"]
+categories = ["parsing"]
+license = "MIT"
+repository = "https://github.com/Geal/nom"
+[package.metadata.docs.rs]
+all-features = true
+features = ["alloc", "std", "docsrs"]
+[profile.bench]
+lto = true
+codegen-units = 1
+debug = true
+
+[[example]]
+name = "json"
+path = "examples/json.rs"
+required-features = ["alloc"]
+
+[[example]]
+name = "iterator"
+path = "examples/iterator.rs"
+
+[[example]]
+name = "s_expression"
+path = "examples/s_expression.rs"
+required-features = ["alloc"]
+
+[[example]]
+name = "string"
+path = "examples/string.rs"
+required-features = ["alloc"]
+
+[[test]]
+name = "arithmetic"
+
+[[test]]
+name = "arithmetic_ast"
+required-features = ["alloc"]
+
+[[test]]
+name = "css"
+
+[[test]]
+name = "custom_errors"
+
+[[test]]
+name = "float"
+
+[[test]]
+name = "ini"
+required-features = ["alloc"]
+
+[[test]]
+name = "ini_str"
+required-features = ["alloc"]
+
+[[test]]
+name = "issues"
+required-features = ["alloc"]
+
+[[test]]
+name = "json"
+
+[[test]]
+name = "mp4"
+required-features = ["alloc"]
+
+[[test]]
+name = "multiline"
+required-features = ["alloc"]
+
+[[test]]
+name = "overflow"
+
+[[test]]
+name = "reborrow_fold"
+
+[[test]]
+name = "fnmut"
+required-features = ["alloc"]
+[dependencies.memchr]
+version = "2.3"
+default-features = false
+
+[dependencies.minimal-lexical]
+version = "0.2.0"
+default-features = false
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[dev-dependencies.proptest]
+version = "1.0.0"
+[build-dependencies.version_check]
+version = "0.9"
+
+[features]
+alloc = []
+default = ["std"]
+docsrs = []
+std = ["alloc", "memchr/std", "minimal-lexical/std"]
+[badges.coveralls]
+branch = "master"
+repository = "Geal/nom"
+service = "github"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+repository = "Geal/nom"