summaryrefslogtreecommitdiffstats
path: root/vendor/odht/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/odht/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/odht/Cargo.toml')
-rw-r--r--vendor/odht/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/vendor/odht/Cargo.toml b/vendor/odht/Cargo.toml
new file mode 100644
index 000000000..f41eb35cb
--- /dev/null
+++ b/vendor/odht/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "odht"
+version = "0.3.1"
+exclude = ["/.github/*"]
+description = "A Rust crate for hash tables that can be mapped from disk into memory without the need for up-front decoding."
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/odht"
+[dependencies.cfg-if]
+version = "1.0.0"
+[dev-dependencies.quickcheck]
+version = "1"
+
+[dev-dependencies.rand]
+version = "0.8.2"
+
+[dev-dependencies.rustc-hash]
+version = "1.1.0"
+
+[features]
+nightly = []
+no_simd = []