summaryrefslogtreecommitdiffstats
path: root/vendor/opener/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/opener/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/opener/Cargo.toml')
-rw-r--r--vendor/opener/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/vendor/opener/Cargo.toml b/vendor/opener/Cargo.toml
new file mode 100644
index 000000000..bbc220c45
--- /dev/null
+++ b/vendor/opener/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "opener"
+version = "0.5.0"
+authors = ["Brian Bowman <seeker14491@gmail.com>"]
+description = "Open a file or link using the system default program."
+readme = "../README.md"
+keywords = ["open", "default", "launcher", "browser"]
+categories = ["os"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Seeker14491/opener"
+[dev-dependencies.version-sync]
+version = "0.9"
+[target."cfg(target_os = \"linux\")".dependencies.bstr]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["shellapi"]
+[badges.appveyor]
+branch = "master"
+repository = "Seeker14491/opener"
+service = "github"
+
+[badges.maintenance]
+status = "passively-maintained"
+
+[badges.travis-ci]
+branch = "master"
+repository = "Seeker14491/opener"