summaryrefslogtreecommitdiffstats
path: root/vendor/os_info/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/os_info/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/os_info/Cargo.toml')
-rw-r--r--vendor/os_info/Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/vendor/os_info/Cargo.toml b/vendor/os_info/Cargo.toml
new file mode 100644
index 000000000..a74fea76d
--- /dev/null
+++ b/vendor/os_info/Cargo.toml
@@ -0,0 +1,64 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "os_info"
+version = "3.5.0"
+authors = [
+ "Jan Schulte <hello@unexpected-co.de>",
+ "Stanislav Tkach <stanislav.tkach@gmail.com>",
+]
+description = "Detect the operating system type and version."
+homepage = "https://github.com/stanislav-tkach/os_info"
+documentation = "https://docs.rs/os_info"
+readme = "README.md"
+keywords = [
+ "os",
+ "os_type",
+ "os_version",
+ "os_info",
+]
+categories = ["os"]
+license = "MIT"
+repository = "https://github.com/stanislav-tkach/os_info"
+
+[dependencies.log]
+version = "0.4.5"
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+optional = true
+
+[dev-dependencies.doc-comment]
+version = "0.3.1"
+
+[dev-dependencies.pretty_assertions]
+version = "1"
+
+[features]
+default = ["serde"]
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.8"
+features = [
+ "minwindef",
+ "ntdef",
+ "ntstatus",
+ "sysinfoapi",
+ "winnt",
+ "winuser",
+ "libloaderapi",
+ "processthreadsapi",
+ "winerror",
+ "winreg",
+]