summaryrefslogtreecommitdiffstats
path: root/vendor/parking_lot/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/parking_lot/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/parking_lot/Cargo.toml')
-rw-r--r--vendor/parking_lot/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/vendor/parking_lot/Cargo.toml b/vendor/parking_lot/Cargo.toml
new file mode 100644
index 000000000..e474f48c6
--- /dev/null
+++ b/vendor/parking_lot/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "parking_lot"
+version = "0.12.1"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "More compact and efficient implementations of the standard synchronization primitives."
+readme = "README.md"
+keywords = [
+ "mutex",
+ "condvar",
+ "rwlock",
+ "once",
+ "thread",
+]
+categories = ["concurrency"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Amanieu/parking_lot"
+
+[dependencies.lock_api]
+version = "0.4.6"
+
+[dependencies.parking_lot_core]
+version = "0.9.0"
+
+[dev-dependencies.bincode]
+version = "1.3.3"
+
+[dev-dependencies.rand]
+version = "0.8.3"
+
+[features]
+arc_lock = ["lock_api/arc_lock"]
+deadlock_detection = ["parking_lot_core/deadlock_detection"]
+default = []
+hardware-lock-elision = []
+nightly = [
+ "parking_lot_core/nightly",
+ "lock_api/nightly",
+]
+owning_ref = ["lock_api/owning_ref"]
+send_guard = []
+serde = ["lock_api/serde"]