summaryrefslogtreecommitdiffstats
path: root/vendor/parking_lot_core-0.8.6/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:41 +0000
commit4f9fe856a25ab29345b90e7725509e9ee38a37be (patch)
treee4ffd8a9374cae7b21f7cbfb352927e0e074aff6 /vendor/parking_lot_core-0.8.6/Cargo.toml
parentAdding upstream version 1.68.2+dfsg1. (diff)
downloadrustc-4f9fe856a25ab29345b90e7725509e9ee38a37be.tar.xz
rustc-4f9fe856a25ab29345b90e7725509e9ee38a37be.zip
Adding upstream version 1.69.0+dfsg1.upstream/1.69.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--vendor/parking_lot_core-0.8.6/Cargo.toml (renamed from vendor/parking_lot_core-0.8.5/Cargo.toml)30
1 files changed, 26 insertions, 4 deletions
diff --git a/vendor/parking_lot_core-0.8.5/Cargo.toml b/vendor/parking_lot_core-0.8.6/Cargo.toml
index 7afeb4114..698151644 100644
--- a/vendor/parking_lot_core-0.8.5/Cargo.toml
+++ b/vendor/parking_lot_core-0.8.6/Cargo.toml
@@ -12,13 +12,20 @@
[package]
edition = "2018"
name = "parking_lot_core"
-version = "0.8.5"
+version = "0.8.6"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
description = "An advanced API for creating custom synchronization primitives."
-keywords = ["mutex", "condvar", "rwlock", "once", "thread"]
+keywords = [
+ "mutex",
+ "condvar",
+ "rwlock",
+ "once",
+ "thread",
+]
categories = ["concurrency"]
license = "Apache-2.0/MIT"
repository = "https://github.com/Amanieu/parking_lot"
+
[dependencies.backtrace]
version = "0.3.60"
optional = true
@@ -41,12 +48,27 @@ version = "4.0.0"
optional = true
[features]
-deadlock_detection = ["petgraph", "thread-id", "backtrace"]
+deadlock_detection = [
+ "petgraph",
+ "thread-id",
+ "backtrace",
+]
nightly = []
+
[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
version = "0.2.8"
+
[target."cfg(unix)".dependencies.libc]
version = "0.2.95"
+
[target."cfg(windows)".dependencies.winapi]
version = "0.3.9"
-features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"]
+features = [
+ "winnt",
+ "ntstatus",
+ "minwindef",
+ "winerror",
+ "winbase",
+ "errhandlingapi",
+ "handleapi",
+]