summaryrefslogtreecommitdiffstats
path: root/vendor/parking_lot_core/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/parking_lot_core/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/parking_lot_core/Cargo.toml')
-rw-r--r--vendor/parking_lot_core/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/vendor/parking_lot_core/Cargo.toml b/vendor/parking_lot_core/Cargo.toml
new file mode 100644
index 000000000..4706c434a
--- /dev/null
+++ b/vendor/parking_lot_core/Cargo.toml
@@ -0,0 +1,68 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "parking_lot_core"
+version = "0.9.3"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "An advanced API for creating custom synchronization primitives."
+keywords = [
+ "mutex",
+ "condvar",
+ "rwlock",
+ "once",
+ "thread",
+]
+categories = ["concurrency"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Amanieu/parking_lot"
+
+[dependencies.backtrace]
+version = "0.3.60"
+optional = true
+
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.petgraph]
+version = "0.6.0"
+optional = true
+
+[dependencies.smallvec]
+version = "1.6.1"
+
+[dependencies.thread-id]
+version = "4.0.0"
+optional = true
+
+[features]
+deadlock_detection = [
+ "petgraph",
+ "thread-id",
+ "backtrace",
+]
+nightly = []
+
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.2.8"
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.95"
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.36.0"
+features = [
+ "Win32_Foundation",
+ "Win32_System_LibraryLoader",
+ "Win32_System_SystemServices",
+ "Win32_System_WindowsProgramming",
+]