summaryrefslogtreecommitdiffstats
path: root/vendor/pest/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /vendor/pest/Cargo.toml
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/pest/Cargo.toml')
-rw-r--r--vendor/pest/Cargo.toml26
1 files changed, 19 insertions, 7 deletions
diff --git a/vendor/pest/Cargo.toml b/vendor/pest/Cargo.toml
index 97246991c..29e54b46f 100644
--- a/vendor/pest/Cargo.toml
+++ b/vendor/pest/Cargo.toml
@@ -10,13 +10,13 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
rust-version = "1.56"
name = "pest"
-version = "2.3.0"
+version = "2.5.2"
authors = ["DragoČ™ Tiselice <dragostiselice@gmail.com>"]
description = "The Elegant Parser"
-homepage = "https://pest-parser.github.io/"
+homepage = "https://pest.rs/"
documentation = "https://docs.rs/pest"
readme = "_README.md"
keywords = [
@@ -29,25 +29,37 @@ categories = ["parsing"]
license = "MIT/Apache-2.0"
repository = "https://github.com/pest-parser/pest"
+[dependencies.bytecount]
+version = "0.6"
+optional = true
+
+[dependencies.memchr]
+version = "2"
+optional = true
+
[dependencies.serde]
-version = "1.0.89"
+version = "1.0.145"
optional = true
[dependencies.serde_json]
-version = "1.0.39"
+version = "1.0.85"
optional = true
[dependencies.thiserror]
-version = "1.0.31"
+version = "1.0.37"
optional = true
[dependencies.ucd-trie]
-version = "0.1.1"
+version = "0.1.5"
default-features = false
[features]
const_prec_climber = []
default = ["std"]
+fast-line-col = [
+ "memchr",
+ "bytecount",
+]
pretty-print = [
"serde",
"serde_json",