summaryrefslogtreecommitdiffstats
path: root/vendor/rand_chacha/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/rand_chacha/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rand_chacha/Cargo.toml')
-rw-r--r--vendor/rand_chacha/Cargo.toml14
1 files changed, 11 insertions, 3 deletions
diff --git a/vendor/rand_chacha/Cargo.toml b/vendor/rand_chacha/Cargo.toml
index 0f371b3c3..c907ae974 100644
--- a/vendor/rand_chacha/Cargo.toml
+++ b/vendor/rand_chacha/Cargo.toml
@@ -13,11 +13,11 @@
[package]
edition = "2018"
name = "rand_chacha"
-version = "0.3.0"
+version = "0.3.1"
authors = ["The Rand Project Developers", "The Rust Project Developers", "The CryptoCorrosion Contributors"]
description = "ChaCha random number generator\n"
-homepage = "https://crates.io/crates/rand_chacha"
-documentation = "https://rust-random.github.io/rand/rand_chacha/"
+homepage = "https://rust-random.github.io/book"
+documentation = "https://docs.rs/rand_chacha"
readme = "README.md"
keywords = ["random", "rng", "chacha"]
categories = ["algorithms", "no-std"]
@@ -31,7 +31,15 @@ default-features = false
[dependencies.rand_core]
version = "0.6.0"
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+[dev-dependencies.serde_json]
+version = "1.0"
+
[features]
default = ["std"]
+serde1 = ["serde"]
simd = []
std = ["ppv-lite86/std"]