summaryrefslogtreecommitdiffstats
path: root/vendor/regex-automata/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
commit5363f350887b1e5b5dd21a86f88c8af9d7fea6da (patch)
tree35ca005eb6e0e9a1ba3bb5dbc033209ad445dc17 /vendor/regex-automata/README.md
parentAdding debian version 1.66.0+dfsg1-1. (diff)
downloadrustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.tar.xz
rustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/regex-automata/README.md')
-rw-r--r--vendor/regex-automata/README.md13
1 files changed, 6 insertions, 7 deletions
diff --git a/vendor/regex-automata/README.md b/vendor/regex-automata/README.md
index 8eaf03f04..23e0bffe0 100644
--- a/vendor/regex-automata/README.md
+++ b/vendor/regex-automata/README.md
@@ -6,7 +6,7 @@ configuring the best space vs time trade off for your use case and provides
support for cheap deserialization of automata for use in `no_std` environments.
[![Build status](https://github.com/BurntSushi/regex-automata/workflows/ci/badge.svg)](https://github.com/BurntSushi/regex-automata/actions)
-[![on crates.io](https://meritbadge.herokuapp.com/regex-automata)](https://crates.io/crates/regex-automata)
+[![Crates.io](https://img.shields.io/crates/v/regex-automata.svg)](https://crates.io/crates/regex-automata)
![Minimum Supported Rust Version 1.41](https://img.shields.io/badge/rustc-1.41-green)
Dual-licensed under MIT or the [UNLICENSE](https://unlicense.org/).
@@ -26,11 +26,10 @@ Add this to your `Cargo.toml`:
regex-automata = "0.1"
```
-and this to your crate root (if you're using Rust 2015):
-
-```rust
-extern crate regex_automata;
-```
+**WARNING**: The `master` branch currently contains code for the `0.2` release,
+but this README still targets the `0.1` release. Namely, it is recommended to
+stick with the `0.1` release. The `0.2` release was made prematurely in order
+to unblock some folks.
### Example: basic regex searching
@@ -48,7 +47,7 @@ assert_eq!(matches, vec![(0, 10), (11, 21)]);
```
For more examples and information about the various knobs that can be turned,
-please see the [docs](https://docs.rs/regex-automata).
+please see the [docs](https://docs.rs/regex-automata/0.1).
### Support for `no_std`