summaryrefslogtreecommitdiffstats
path: root/vendor/rls-data/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/rls-data/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rls-data/Cargo.toml')
-rw-r--r--vendor/rls-data/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/vendor/rls-data/Cargo.toml b/vendor/rls-data/Cargo.toml
new file mode 100644
index 000000000..54d416498
--- /dev/null
+++ b/vendor/rls-data/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rls-data"
+version = "0.19.1"
+authors = ["Nick Cameron <ncameron@mozilla.com>"]
+description = "Data structures used by the RLS and Rust compiler"
+categories = ["development-tools"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/rust-lang/rls"
+[dependencies.rls-span]
+version = "0.5.0"
+
+[dependencies.serde]
+version = "1.0"
+
+[features]
+default = ["derive"]
+derive = ["serde/derive", "rls-span/derive"]