summaryrefslogtreecommitdiffstats
path: root/vendor/rustix/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:21 +0000
commit4e8199b572f2035b7749cba276ece3a26630d23e (patch)
treef09feeed6a0fe39d027b1908aa63ea6b35e4b631 /vendor/rustix/Cargo.toml
parentAdding upstream version 1.66.0+dfsg1. (diff)
downloadrustc-4e8199b572f2035b7749cba276ece3a26630d23e.tar.xz
rustc-4e8199b572f2035b7749cba276ece3a26630d23e.zip
Adding upstream version 1.67.1+dfsg1.upstream/1.67.1+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rustix/Cargo.toml')
-rw-r--r--vendor/rustix/Cargo.toml59
1 files changed, 33 insertions, 26 deletions
diff --git a/vendor/rustix/Cargo.toml b/vendor/rustix/Cargo.toml
index 95221b2dd..25acf14fd 100644
--- a/vendor/rustix/Cargo.toml
+++ b/vendor/rustix/Cargo.toml
@@ -12,17 +12,23 @@
[package]
edition = "2018"
name = "rustix"
-version = "0.35.6"
+version = "0.36.3"
authors = [
"Dan Gohman <dev@sunfishcode.online>",
"Jakub Konka <kubkon@jakubkonka.com>",
]
-exclude = [
- "/.*",
- "test-crates",
+include = [
+ "src",
+ "build.rs",
+ "Cargo.toml",
+ "COPYRIGHT",
+ "LICENSE*",
+ "/*.md",
+ "benches",
]
description = "Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls"
documentation = "https://docs.rs/rustix"
+readme = "README.md"
keywords = [
"api",
"file",
@@ -74,7 +80,8 @@ optional = true
package = "rustc-std-workspace-core"
[dependencies.io-lifetimes]
-version = "0.7.0"
+version = "1.0.0"
+features = ["close"]
optional = true
default-features = false
@@ -83,19 +90,24 @@ version = "1.0.1"
optional = true
default-features = false
+[dev-dependencies.flate2]
+version = "1.0"
+
[dev-dependencies.io-lifetimes]
-version = "0.7.0"
+version = "1.0.0"
+features = ["close"]
default-features = false
[dev-dependencies.libc]
-version = "0.2.126"
+version = "0.2.133"
[dev-dependencies.libc_errno]
version = "0.2.8"
+default-features = false
package = "errno"
[dev-dependencies.memoffset]
-version = "0.6.5"
+version = "0.7.1"
[dev-dependencies.serial_test]
version = "0.6"
@@ -123,24 +135,20 @@ all-apis = [
"time",
]
all-impls = [
- "async-std",
- "tokio",
"os_pipe",
- "socket2",
- "mio",
"fs-err",
]
-async-std = ["io-lifetimes/async-std"]
-default = ["std"]
+default = [
+ "std",
+ "use-libc-auxv",
+]
fs = []
fs-err = ["io-lifetimes/fs-err"]
io_uring = [
- "linux-raw-sys",
"fs",
"net",
]
-mio = ["io-lifetimes/mio"]
-mm = ["linux-raw-sys"]
+mm = []
net = []
os_pipe = ["io-lifetimes/os_pipe"]
param = []
@@ -148,6 +156,7 @@ process = []
procfs = [
"once_cell",
"itoa",
+ "fs",
]
rand = []
runtime = []
@@ -158,28 +167,26 @@ rustc-dep-of-std = [
"linux-raw-sys/rustc-dep-of-std",
"bitflags/rustc-dep-of-std",
]
-socket2 = ["io-lifetimes/socket2"]
std = ["io-lifetimes"]
termios = []
thread = []
time = []
-tokio = ["io-lifetimes/tokio"]
use-libc = [
"libc_errno",
"libc",
]
+use-libc-auxv = ["libc"]
[target."cfg(all(any(target_os = \"android\", target_os = \"linux\"), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.linux-raw-sys]
-version = "0.0.46"
+version = "0.1.2"
features = [
"general",
"no_std",
]
-optional = true
default-features = false
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc]
-version = "0.2.126"
+version = "0.2.133"
features = ["extra_traits"]
optional = true
@@ -190,7 +197,7 @@ default-features = false
package = "errno"
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.linux-raw-sys]
-version = "0.0.46"
+version = "0.1.2"
features = [
"general",
"errno",
@@ -200,7 +207,7 @@ features = [
default-features = false
[target."cfg(any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))))".dependencies.libc]
-version = "0.2.126"
+version = "0.2.133"
features = ["extra_traits"]
[target."cfg(any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))))".dependencies.libc_errno]
@@ -213,10 +220,10 @@ version = "1.5.2"
optional = true
[target."cfg(not(target_os = \"emscripten\"))".dev-dependencies.criterion]
-version = "0.3"
+version = "0.4"
[target."cfg(windows)".dependencies.windows-sys]
-version = "0.36.0"
+version = "0.42.0"
features = [
"Win32_Foundation",
"Win32_Networking_WinSock",