summaryrefslogtreecommitdiffstats
path: root/vendor/rustix/tests/time/dynamic_clocks.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/rustix/tests/time/dynamic_clocks.rs
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rustix/tests/time/dynamic_clocks.rs')
-rw-r--r--vendor/rustix/tests/time/dynamic_clocks.rs22
1 files changed, 22 insertions, 0 deletions
diff --git a/vendor/rustix/tests/time/dynamic_clocks.rs b/vendor/rustix/tests/time/dynamic_clocks.rs
new file mode 100644
index 000000000..a7e1e6792
--- /dev/null
+++ b/vendor/rustix/tests/time/dynamic_clocks.rs
@@ -0,0 +1,22 @@
+#![cfg(not(any(target_os = "redox", target_os = "wasi")))]
+
+use rustix::fd::AsFd;
+use rustix::time::{clock_gettime_dynamic, ClockId, DynamicClockId};
+
+#[test]
+fn test_known_clocks() {
+ clock_gettime_dynamic(DynamicClockId::Known(ClockId::Realtime)).unwrap();
+ clock_gettime_dynamic(DynamicClockId::Known(ClockId::Monotonic)).unwrap();
+}
+
+#[test]
+fn test_dynamic_clocks() {
+ let file = std::fs::File::open("Cargo.toml").unwrap();
+ clock_gettime_dynamic(DynamicClockId::Dynamic(file.as_fd())).unwrap_err();
+}
+
+#[cfg(any(target_os = "android", target_os = "linux"))]
+#[test]
+fn test_conditional_clocks() {
+ let _ = clock_gettime_dynamic(DynamicClockId::Tai);
+}