summaryrefslogtreecommitdiffstats
path: root/vendor/self_cell/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/self_cell/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/self_cell/Cargo.toml')
-rw-r--r--vendor/self_cell/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/vendor/self_cell/Cargo.toml b/vendor/self_cell/Cargo.toml
new file mode 100644
index 000000000..f8ba952e5
--- /dev/null
+++ b/vendor/self_cell/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "self_cell"
+version = "0.10.2"
+authors = ["Lukas Bergdoll <lukas.bergdoll@gmail.com>"]
+include = ["src/*.rs", "Cargo.toml", "README.md", "LICENSE"]
+description = "Safe-to-use proc-macro-free self-referential structs in stable Rust."
+documentation = "https://docs.rs/self_cell"
+readme = "README.md"
+keywords = ["lifetime", "borrowing", "self", "reference", "intrusive"]
+categories = ["rust-patterns", "memory-management"]
+license = "Apache-2.0"
+repository = "https://github.com/Voultapher/self_cell"
+[dependencies.rustversion]
+version = ">=1"
+optional = true
+[dev-dependencies.once_cell]
+version = ">=1"
+
+[features]
+old_rust = ["rustversion"]