summaryrefslogtreecommitdiffstats
path: root/vendor/sha-1-0.8.2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/sha-1-0.8.2/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--vendor/sha-1-0.8.2/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/vendor/sha-1-0.8.2/Cargo.toml b/vendor/sha-1-0.8.2/Cargo.toml
new file mode 100644
index 000000000..a230700c7
--- /dev/null
+++ b/vendor/sha-1-0.8.2/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "sha-1"
+version = "0.8.2"
+authors = ["RustCrypto Developers"]
+description = "SHA-1 hash function"
+documentation = "https://docs.rs/sha-1"
+keywords = ["crypto", "sha1", "hash", "digest"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/hashes"
+
+[lib]
+name = "sha1"
+[dependencies.block-buffer]
+version = "0.7"
+
+[dependencies.digest]
+version = "0.8"
+
+[dependencies.fake-simd]
+version = "0.1"
+
+[dependencies.libc]
+version = "0.2"
+optional = true
+
+[dependencies.opaque-debug]
+version = "0.2"
+
+[dependencies.sha1-asm]
+version = "0.4"
+optional = true
+[dev-dependencies.digest]
+version = "0.8"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.1"
+
+[features]
+asm = ["sha1-asm"]
+asm-aarch64 = ["asm", "libc"]
+default = ["std"]
+std = ["digest/std"]
+[badges.travis-ci]
+repository = "RustCrypto/hashes"