summaryrefslogtreecommitdiffstats
path: root/vendor/sha1_smol/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/sha1_smol/Makefile
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/sha1_smol/Makefile')
-rw-r--r--vendor/sha1_smol/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/vendor/sha1_smol/Makefile b/vendor/sha1_smol/Makefile
new file mode 100644
index 000000000..256f7fb86
--- /dev/null
+++ b/vendor/sha1_smol/Makefile
@@ -0,0 +1,18 @@
+build:
+ @cargo build
+
+watch:
+ @cargo watch
+
+watch-docs:
+ @cargo watch build "doc --no-deps"
+
+test:
+ @cargo test --features=serde
+ @cargo test --features=std
+ @cargo test
+
+docs: build
+ @cargo doc --no-deps
+
+.PHONY: build test docs