summaryrefslogtreecommitdiffstats
path: root/vendor/stacker/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
commit5363f350887b1e5b5dd21a86f88c8af9d7fea6da (patch)
tree35ca005eb6e0e9a1ba3bb5dbc033209ad445dc17 /vendor/stacker/Cargo.toml
parentAdding debian version 1.66.0+dfsg1-1. (diff)
downloadrustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.tar.xz
rustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/stacker/Cargo.toml')
-rw-r--r--vendor/stacker/Cargo.toml36
1 files changed, 25 insertions, 11 deletions
diff --git a/vendor/stacker/Cargo.toml b/vendor/stacker/Cargo.toml
index f61a0315b..160cbc017 100644
--- a/vendor/stacker/Cargo.toml
+++ b/vendor/stacker/Cargo.toml
@@ -3,29 +3,35 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
name = "stacker"
-version = "0.1.14"
-authors = ["Alex Crichton <alex@alexcrichton.com>", "Simonas Kazlauskas <git@kazlauskas.me>"]
+version = "0.1.15"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Simonas Kazlauskas <stacker@kazlauskas.me>",
+]
build = "build.rs"
-description = "A stack growth library useful when implementing deeply recursive algorithms that\nmay accidentally blow the stack.\n"
+description = """
+A stack growth library useful when implementing deeply recursive algorithms that
+may accidentally blow the stack.
+"""
homepage = "https://github.com/rust-lang/stacker"
-documentation = "https://docs.rs/stacker/0.1.14"
+documentation = "https://docs.rs/stacker/0.1.15"
readme = "README.md"
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/stacker"
[lib]
name = "stacker"
test = false
doctest = false
+
[dependencies.cfg-if]
version = "1.0.0"
@@ -34,8 +40,16 @@ version = "0.2.45"
[dependencies.psm]
version = "0.1.7"
+
[build-dependencies.cc]
version = "1.0.2"
+
[target."cfg(windows)".dependencies.winapi]
version = "0.3.6"
-features = ["memoryapi", "winbase", "fibersapi", "processthreadsapi", "minwindef"]
+features = [
+ "memoryapi",
+ "winbase",
+ "fibersapi",
+ "processthreadsapi",
+ "minwindef",
+]