summaryrefslogtreecommitdiffstats
path: root/vendor/stacker
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
commit5363f350887b1e5b5dd21a86f88c8af9d7fea6da (patch)
tree35ca005eb6e0e9a1ba3bb5dbc033209ad445dc17 /vendor/stacker
parentAdding debian version 1.66.0+dfsg1-1. (diff)
downloadrustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.tar.xz
rustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/stacker')
-rw-r--r--vendor/stacker/.cargo-checksum.json2
-rw-r--r--vendor/stacker/Cargo.toml36
-rw-r--r--vendor/stacker/README.md4
-rw-r--r--vendor/stacker/src/lib.rs6
4 files changed, 32 insertions, 16 deletions
diff --git a/vendor/stacker/.cargo-checksum.json b/vendor/stacker/.cargo-checksum.json
index 8ba471a9c..767fe6f38 100644
--- a/vendor/stacker/.cargo-checksum.json
+++ b/vendor/stacker/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"2f4bee8a3114353b7123969903b52d6b7c04412a848bf607f784bc8cb56a3b80","Cross.toml":"b5f300c31f4522caba733582f4957f693a4017f4728a69805390b63ad69eff67","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","README.md":"e938c263b76ff66671013f0f77755aa289e807d91b7d39471ba92dea6782929e","build.rs":"8a9274309128a737566386f2534a93c69d2991da19a4543113790bc819448a53","src/arch/asm.h":"4c4db945e854e4ce3f0b7ba8da3755613c0e4513a7aab0604bd6a67c0ff2192d","src/arch/windows.c":"e98e08f6b5102480b8fa4dfa7ee13441845202f5ba81c60b13da2800e0a8630c","src/lib.rs":"cee329550bad2ed1182abb71db9c24558a91b12e1eab8d9a48e23b997bb8f04e","tests/simple.rs":"18fbb3e891ab486c58aa011698f755945818db8799c564f2fa8cfe5ac8d8f0dc","tests/smoke.rs":"db4fd5b210123d9643aefd703be324d626d4b0f9398d7cae7f30871fba71f65b"},"package":"90939d5171a4420b3ff5fbc8954d641e7377335454c259dcb80786f3f21dc9b4"} \ No newline at end of file
+{"files":{"Cargo.toml":"60bfff5e991ac892e755d65611b9676971fbafbc144e1f929999a1b677b66a0e","Cross.toml":"b5f300c31f4522caba733582f4957f693a4017f4728a69805390b63ad69eff67","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","README.md":"c9071baf1061060b97f9ebaf7c70b1d85eef76042b53e520109d331a40a15092","build.rs":"8a9274309128a737566386f2534a93c69d2991da19a4543113790bc819448a53","src/arch/asm.h":"4c4db945e854e4ce3f0b7ba8da3755613c0e4513a7aab0604bd6a67c0ff2192d","src/arch/windows.c":"e98e08f6b5102480b8fa4dfa7ee13441845202f5ba81c60b13da2800e0a8630c","src/lib.rs":"59ca847887cf19387119d18c57f08d5a8520d714876ca0142b8f1c001ecde06b","tests/simple.rs":"18fbb3e891ab486c58aa011698f755945818db8799c564f2fa8cfe5ac8d8f0dc","tests/smoke.rs":"db4fd5b210123d9643aefd703be324d626d4b0f9398d7cae7f30871fba71f65b"},"package":"c886bd4480155fd3ef527d45e9ac8dd7118a898a46530b7b94c3e21866259fce"} \ No newline at end of file
diff --git a/vendor/stacker/Cargo.toml b/vendor/stacker/Cargo.toml
index f61a0315b..160cbc017 100644
--- a/vendor/stacker/Cargo.toml
+++ b/vendor/stacker/Cargo.toml
@@ -3,29 +3,35 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
name = "stacker"
-version = "0.1.14"
-authors = ["Alex Crichton <alex@alexcrichton.com>", "Simonas Kazlauskas <git@kazlauskas.me>"]
+version = "0.1.15"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Simonas Kazlauskas <stacker@kazlauskas.me>",
+]
build = "build.rs"
-description = "A stack growth library useful when implementing deeply recursive algorithms that\nmay accidentally blow the stack.\n"
+description = """
+A stack growth library useful when implementing deeply recursive algorithms that
+may accidentally blow the stack.
+"""
homepage = "https://github.com/rust-lang/stacker"
-documentation = "https://docs.rs/stacker/0.1.14"
+documentation = "https://docs.rs/stacker/0.1.15"
readme = "README.md"
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/stacker"
[lib]
name = "stacker"
test = false
doctest = false
+
[dependencies.cfg-if]
version = "1.0.0"
@@ -34,8 +40,16 @@ version = "0.2.45"
[dependencies.psm]
version = "0.1.7"
+
[build-dependencies.cc]
version = "1.0.2"
+
[target."cfg(windows)".dependencies.winapi]
version = "0.3.6"
-features = ["memoryapi", "winbase", "fibersapi", "processthreadsapi", "minwindef"]
+features = [
+ "memoryapi",
+ "winbase",
+ "fibersapi",
+ "processthreadsapi",
+ "minwindef",
+]
diff --git a/vendor/stacker/README.md b/vendor/stacker/README.md
index c8d39a6f6..94858e4b2 100644
--- a/vendor/stacker/README.md
+++ b/vendor/stacker/README.md
@@ -31,9 +31,9 @@ typically in place.
This project is licensed under either of
* Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
- http://www.apache.org/licenses/LICENSE-2.0)
+ https://www.apache.org/licenses/LICENSE-2.0)
* MIT license ([LICENSE-MIT](LICENSE-MIT) or
- http://opensource.org/licenses/MIT)
+ https://opensource.org/licenses/MIT)
at your option.
diff --git a/vendor/stacker/src/lib.rs b/vendor/stacker/src/lib.rs
index 3c1d8891e..ec0a55f9d 100644
--- a/vendor/stacker/src/lib.rs
+++ b/vendor/stacker/src/lib.rs
@@ -164,7 +164,8 @@ psm_stack_manipulation! {
0
);
if new_stack == libc::MAP_FAILED {
- panic!("unable to allocate stack")
+ let error = std::io::Error::last_os_error();
+ panic!("allocating stack failed with: {}", error)
}
let guard = StackRestoreGuard {
new_stack,
@@ -191,8 +192,9 @@ psm_stack_manipulation! {
-1
};
if result == -1 {
+ let error = std::io::Error::last_os_error();
drop(guard);
- panic!("unable to set stack permissions")
+ panic!("setting stack permissions failed with: {}", error)
}
guard
}