summaryrefslogtreecommitdiffstats
path: root/vendor/static_assertions/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /vendor/static_assertions/Cargo.toml
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/static_assertions/Cargo.toml')
-rw-r--r--vendor/static_assertions/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/vendor/static_assertions/Cargo.toml b/vendor/static_assertions/Cargo.toml
new file mode 100644
index 000000000..8651ce1ee
--- /dev/null
+++ b/vendor/static_assertions/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "static_assertions"
+version = "1.1.0"
+authors = ["Nikolai Vazquez"]
+include = ["Cargo.toml", "src/**/*.rs", "README.md", "CHANGELOG.md", "LICENSE*"]
+description = "Compile-time assertions to ensure that invariants are met."
+homepage = "https://github.com/nvzqz/static-assertions-rs"
+documentation = "https://docs.rs/static_assertions/"
+readme = "README.md"
+keywords = ["assert", "static", "testing"]
+categories = ["no-std", "rust-patterns", "development-tools::testing"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/nvzqz/static-assertions-rs"
+
+[features]
+nightly = []
+[badges.is-it-maintained-issue-resolution]
+repository = "nvzqz/static-assertions-rs"
+
+[badges.is-it-maintained-open-issues]
+repository = "nvzqz/static-assertions-rs"
+
+[badges.maintenance]
+status = "passively-maintained"
+
+[badges.travis-ci]
+repository = "nvzqz/static-assertions-rs"