summaryrefslogtreecommitdiffstats
path: root/vendor/subtle/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
commita0b8f38ab54ac451646aa00cd5e91b6c76f22a84 (patch)
treefc451898ccaf445814e26b46664d78702178101d /vendor/subtle/Cargo.toml
parentAdding debian version 1.71.1+dfsg1-2. (diff)
downloadrustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.tar.xz
rustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/subtle/Cargo.toml')
-rw-r--r--vendor/subtle/Cargo.toml16
1 files changed, 9 insertions, 7 deletions
diff --git a/vendor/subtle/Cargo.toml b/vendor/subtle/Cargo.toml
index 8689ad2f7..351989ace 100644
--- a/vendor/subtle/Cargo.toml
+++ b/vendor/subtle/Cargo.toml
@@ -3,16 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
name = "subtle"
-version = "2.4.1"
+version = "2.5.0"
authors = ["Isis Lovecruft <isis@patternsinthevoid.net>", "Henry de Valence <hdevalence@hdevalence.ca>"]
exclude = ["**/.gitignore", ".travis.yml"]
description = "Pure-Rust traits and utilities for constant-time cryptographic implementations."
@@ -24,9 +24,11 @@ categories = ["cryptography", "no-std"]
license = "BSD-3-Clause"
repository = "https://github.com/dalek-cryptography/subtle"
[dev-dependencies.rand]
-version = "0.7"
+version = "0.8"
[features]
+const-generics = []
+core_hint_black_box = []
default = ["std", "i128"]
i128 = []
nightly = []