summaryrefslogtreecommitdiffstats
path: root/vendor/synstructure-0.12.6/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /vendor/synstructure-0.12.6/Cargo.toml
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/synstructure-0.12.6/Cargo.toml')
-rw-r--r--vendor/synstructure-0.12.6/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/vendor/synstructure-0.12.6/Cargo.toml b/vendor/synstructure-0.12.6/Cargo.toml
new file mode 100644
index 000000000..03398567e
--- /dev/null
+++ b/vendor/synstructure-0.12.6/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "synstructure"
+version = "0.12.6"
+authors = ["Nika Layzell <nika@thelayzells.com>"]
+include = ["src/**/*", "Cargo.toml", "README.md", "LICENSE"]
+description = "Helper methods and macros for custom derives"
+documentation = "https://docs.rs/synstructure"
+readme = "README.md"
+keywords = ["syn", "macros", "derive", "expand_substructure", "enum"]
+license = "MIT"
+repository = "https://github.com/mystor/synstructure"
+[dependencies.proc-macro2]
+version = "1"
+default-features = false
+
+[dependencies.quote]
+version = "1"
+default-features = false
+
+[dependencies.syn]
+version = "1"
+features = ["derive", "parsing", "printing", "clone-impls", "visit", "extra-traits"]
+default-features = false
+
+[dependencies.unicode-xid]
+version = "0.2"
+[dev-dependencies.synstructure_test_traits]
+version = "0.1"
+
+[features]
+default = ["proc-macro"]
+proc-macro = ["proc-macro2/proc-macro", "syn/proc-macro", "quote/proc-macro"]