summaryrefslogtreecommitdiffstats
path: root/vendor/tempfile/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:25 +0000
commit5363f350887b1e5b5dd21a86f88c8af9d7fea6da (patch)
tree35ca005eb6e0e9a1ba3bb5dbc033209ad445dc17 /vendor/tempfile/Cargo.toml
parentAdding debian version 1.66.0+dfsg1-1. (diff)
downloadrustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.tar.xz
rustc-5363f350887b1e5b5dd21a86f88c8af9d7fea6da.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tempfile/Cargo.toml')
-rw-r--r--vendor/tempfile/Cargo.toml26
1 files changed, 15 insertions, 11 deletions
diff --git a/vendor/tempfile/Cargo.toml b/vendor/tempfile/Cargo.toml
index 036714356..253f8667b 100644
--- a/vendor/tempfile/Cargo.toml
+++ b/vendor/tempfile/Cargo.toml
@@ -3,17 +3,16 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "tempfile"
-version = "3.2.0"
+version = "3.3.0"
authors = ["Steven Allen <steven@stebalien.com>", "The Rust Project Developers", "Ashley Mannix <ashleymannix@live.com.au>", "Jason White <jasonaw0@gmail.com>"]
exclude = ["/.travis.yml", "/appveyor.yml"]
description = "A library for managing temporary files and directories."
@@ -25,15 +24,20 @@ repository = "https://github.com/Stebalien/tempfile"
[dependencies.cfg-if]
version = "1"
-[dependencies.rand]
-version = "0.8"
+[dependencies.fastrand]
+version = "1.6.0"
[dependencies.remove_dir_all]
version = "0.5"
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2"
-[target."cfg(unix)".dependencies.libc]
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[features]
+nightly = []
+[target."cfg(any(unix, target_os = \"wasi\"))".dependencies.libc]
version = "0.2.27"
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.2.9"
[target."cfg(windows)".dependencies.winapi]
version = "0.3"
features = ["fileapi", "handleapi", "winbase"]