summaryrefslogtreecommitdiffstats
path: root/vendor/termcolor
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /vendor/termcolor
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/termcolor')
-rw-r--r--vendor/termcolor/.cargo-checksum.json2
-rw-r--r--vendor/termcolor/Cargo.toml30
-rw-r--r--vendor/termcolor/README.md4
-rw-r--r--vendor/termcolor/src/lib.rs16
4 files changed, 38 insertions, 14 deletions
diff --git a/vendor/termcolor/.cargo-checksum.json b/vendor/termcolor/.cargo-checksum.json
index b4df1ed20..9994c6f1e 100644
--- a/vendor/termcolor/.cargo-checksum.json
+++ b/vendor/termcolor/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"COPYING":"01c266bced4a434da0051174d6bee16a4c82cf634e2679b6155d40d75012390f","Cargo.toml":"8d7cf2f58e13533f446cfe1d0c045461974d05d675c1dbda029d912a491d7271","LICENSE-MIT":"0f96a83840e146e43c0ec96a22ec1f392e0680e6c1226e6f3ba87e0740af850f","README.md":"5818a900b5f23ed13e824479c4739e3afe7929a5a08e0dcfdf2cc61ba019d986","UNLICENSE":"7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c","rustfmt.toml":"1ca600239a27401c4a43f363cf3f38183a212affc1f31bff3ae93234bbaec228","src/lib.rs":"5aa9530c1de59aa0f19b035270f87e10397ef37eba317366b9504058364f1d78"},"package":"2dfed899f0eb03f32ee8c6a0aabdb8a7949659e3466561fc0adf54e26d88c5f4"} \ No newline at end of file
+{"files":{"COPYING":"01c266bced4a434da0051174d6bee16a4c82cf634e2679b6155d40d75012390f","Cargo.toml":"c9cf1882497f275a2607a7a3bbee959c90cc9664832f2a4e2a26005e21795834","LICENSE-MIT":"0f96a83840e146e43c0ec96a22ec1f392e0680e6c1226e6f3ba87e0740af850f","README.md":"cc4c882bde8d2ef26ef4770ff30d60eda603d87ae32e16d99525dc88f3377238","UNLICENSE":"7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c","rustfmt.toml":"1ca600239a27401c4a43f363cf3f38183a212affc1f31bff3ae93234bbaec228","src/lib.rs":"91e857a8937bebc50b38a365a3f5138c5898648a14e4b73b84d067c9251cff02"},"package":"bab24d30b911b2376f3a13cc2cd443142f0c81dda04c118693e35b3835757755"} \ No newline at end of file
diff --git a/vendor/termcolor/Cargo.toml b/vendor/termcolor/Cargo.toml
index 344e18bbb..9a996a591 100644
--- a/vendor/termcolor/Cargo.toml
+++ b/vendor/termcolor/Cargo.toml
@@ -3,24 +3,35 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "termcolor"
-version = "1.1.2"
+version = "1.1.3"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/.travis.yml", "/appveyor.yml", "/ci/**"]
-description = "A simple cross platform library for writing colored text to a terminal.\n"
+exclude = [
+ "/.travis.yml",
+ "/appveyor.yml",
+ "/ci/**",
+]
+description = """
+A simple cross platform library for writing colored text to a terminal.
+"""
homepage = "https://github.com/BurntSushi/termcolor"
documentation = "https://docs.rs/termcolor"
readme = "README.md"
-keywords = ["windows", "win", "color", "ansi", "console"]
+keywords = [
+ "windows",
+ "win",
+ "color",
+ "ansi",
+ "console",
+]
license = "Unlicense OR MIT"
repository = "https://github.com/BurntSushi/termcolor"
@@ -28,6 +39,5 @@ repository = "https://github.com/BurntSushi/termcolor"
name = "termcolor"
bench = false
-[dev-dependencies]
[target."cfg(windows)".dependencies.winapi-util]
version = "0.1.3"
diff --git a/vendor/termcolor/README.md b/vendor/termcolor/README.md
index 1c91d07bf..646e3b5ee 100644
--- a/vendor/termcolor/README.md
+++ b/vendor/termcolor/README.md
@@ -9,7 +9,7 @@ applications.
[![Build status](https://github.com/BurntSushi/termcolor/workflows/ci/badge.svg)](https://github.com/BurntSushi/termcolor/actions)
[![](https://img.shields.io/crates/v/termcolor.svg)](https://crates.io/crates/termcolor)
-Dual-licensed under MIT or the [UNLICENSE](http://unlicense.org).
+Dual-licensed under MIT or the [UNLICENSE](https://unlicense.org/).
### Documentation
@@ -85,7 +85,7 @@ fn write_green() -> io::Result<()> {
### Automatic color selection
When building a writer with termcolor, the caller must provide a
-[`ColorChoice`](https://docs.rs/termcolor/1.0.5/termcolor/enum.ColorChoice.html)
+[`ColorChoice`](https://docs.rs/termcolor/1.*/termcolor/enum.ColorChoice.html)
selection. When the color choice is `Auto`, termcolor will attempt to determine
whether colors should be enabled by inspecting the environment. Currently,
termcolor will inspect the `TERM` and `NO_COLOR` environment variables:
diff --git a/vendor/termcolor/src/lib.rs b/vendor/termcolor/src/lib.rs
index 735ce97d2..c93cf7bc8 100644
--- a/vendor/termcolor/src/lib.rs
+++ b/vendor/termcolor/src/lib.rs
@@ -82,7 +82,7 @@ In many scenarios when using color, one often wants to enable colors
automatically when writing to a terminal and disable colors automatically when
writing to anything else. The typical way to achieve this in Unix environments
is via libc's
-[`isatty`](http://man7.org/linux/man-pages/man3/isatty.3.html)
+[`isatty`](https://man7.org/linux/man-pages/man3/isatty.3.html)
function.
Unfortunately, this notoriously does not work well in Windows environments. To
work around that, the currently recommended solution is to use the
@@ -1450,6 +1450,20 @@ impl<W: io::Write> Ansi<W> {
}
}
+impl WriteColor for io::Sink {
+ fn supports_color(&self) -> bool {
+ false
+ }
+
+ fn set_color(&mut self, _: &ColorSpec) -> io::Result<()> {
+ Ok(())
+ }
+
+ fn reset(&mut self) -> io::Result<()> {
+ Ok(())
+ }
+}
+
/// An in-memory buffer that provides Windows console coloring.
///
/// This doesn't actually communicate with the Windows console. Instead, it