summaryrefslogtreecommitdiffstats
path: root/vendor/terminal_size
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /vendor/terminal_size
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/terminal_size')
-rw-r--r--vendor/terminal_size/.cargo-checksum.json1
-rw-r--r--vendor/terminal_size/Cargo.lock159
-rw-r--r--vendor/terminal_size/Cargo.toml39
-rw-r--r--vendor/terminal_size/LICENSE-APACHE202
-rw-r--r--vendor/terminal_size/LICENSE-MIT19
-rw-r--r--vendor/terminal_size/README.md41
-rw-r--r--vendor/terminal_size/examples/get_size.rs52
-rw-r--r--vendor/terminal_size/src/lib.rs37
-rw-r--r--vendor/terminal_size/src/unix.rs111
-rw-r--r--vendor/terminal_size/src/windows.rs52
10 files changed, 713 insertions, 0 deletions
diff --git a/vendor/terminal_size/.cargo-checksum.json b/vendor/terminal_size/.cargo-checksum.json
new file mode 100644
index 000000000..320e5e5d9
--- /dev/null
+++ b/vendor/terminal_size/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.lock":"1fcf7a7c6877d467b346e4250a183cc2d60ceceb99f299c66751f18133615fbf","Cargo.toml":"6b62e7f636e84c7a5c3d71a28253a5f0f07b8d886820cd31c8e817a128ccd5f4","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"bc8dcbbd559a61b8a8c0c89d5c3e15d0dc47c6fae94e78ac428d6a7b7da3c4f9","README.md":"0043c89f8f64fd70d1b90b987844b41be44aceef2553cb5a2f0bd8959e22a55f","examples/get_size.rs":"17d78faa2baba7377eabc4a1737ea12adaee484fd6f86319809b2c70d34bf9c7","src/lib.rs":"5b754f981fbc2fb13ccb3566033eb64e98120dda2bbd158a7a1c8f57488251b6","src/unix.rs":"dbf2c89aeb581ba1c84cb4b7e6ee145f8c3b116e83d9f2b04ae1627da13d6a3a","src/windows.rs":"e68862cfbe69f110e12ed2a82ab77dd80ba848bcbbcd285e271a0de85f330b58"},"package":"cb20089a8ba2b69debd491f8d2d023761cbf196e999218c591fa1e7e15a21907"} \ No newline at end of file
diff --git a/vendor/terminal_size/Cargo.lock b/vendor/terminal_size/Cargo.lock
new file mode 100644
index 000000000..a39bc4e83
--- /dev/null
+++ b/vendor/terminal_size/Cargo.lock
@@ -0,0 +1,159 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+version = 3
+
+[[package]]
+name = "bitflags"
+version = "1.3.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "bef38d45163c2f1dde094a7dfd33ccf595c92905c8f8f4fdc18d06fb1037718a"
+
+[[package]]
+name = "cc"
+version = "1.0.73"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "2fff2a6927b3bb87f9595d67196a70493f627687a71d87a0d692242c33f58c11"
+
+[[package]]
+name = "errno"
+version = "0.2.8"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "f639046355ee4f37944e44f60642c6f3a7efa3cf6b78c78a0d989a8ce6c396a1"
+dependencies = [
+ "errno-dragonfly",
+ "libc",
+ "winapi",
+]
+
+[[package]]
+name = "errno-dragonfly"
+version = "0.1.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "aa68f1b12764fab894d2755d2518754e71b4fd80ecfb822714a1206c2aab39bf"
+dependencies = [
+ "cc",
+ "libc",
+]
+
+[[package]]
+name = "io-lifetimes"
+version = "1.0.3"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "46112a93252b123d31a119a8d1a1ac19deac4fac6e0e8b0df58f0d4e5870e63c"
+dependencies = [
+ "libc",
+ "windows-sys",
+]
+
+[[package]]
+name = "libc"
+version = "0.2.137"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "fc7fcc620a3bff7cdd7a365be3376c97191aeaccc2a603e600951e452615bf89"
+
+[[package]]
+name = "linux-raw-sys"
+version = "0.1.3"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "8f9f08d8963a6c613f4b1a78f4f4a4dbfadf8e6545b2d72861731e4858b8b47f"
+
+[[package]]
+name = "rustix"
+version = "0.36.4"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "cb93e85278e08bb5788653183213d3a60fc242b10cb9be96586f5a73dcb67c23"
+dependencies = [
+ "bitflags",
+ "errno",
+ "io-lifetimes",
+ "libc",
+ "linux-raw-sys",
+ "windows-sys",
+]
+
+[[package]]
+name = "terminal_size"
+version = "0.2.3"
+dependencies = [
+ "rustix",
+ "windows-sys",
+]
+
+[[package]]
+name = "winapi"
+version = "0.3.9"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "5c839a674fcd7a98952e593242ea400abe93992746761e38641405d28b00f419"
+dependencies = [
+ "winapi-i686-pc-windows-gnu",
+ "winapi-x86_64-pc-windows-gnu",
+]
+
+[[package]]
+name = "winapi-i686-pc-windows-gnu"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
+
+[[package]]
+name = "winapi-x86_64-pc-windows-gnu"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
+
+[[package]]
+name = "windows-sys"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "5a3e1820f08b8513f676f7ab6c1f99ff312fb97b553d30ff4dd86f9f15728aa7"
+dependencies = [
+ "windows_aarch64_gnullvm",
+ "windows_aarch64_msvc",
+ "windows_i686_gnu",
+ "windows_i686_msvc",
+ "windows_x86_64_gnu",
+ "windows_x86_64_gnullvm",
+ "windows_x86_64_msvc",
+]
+
+[[package]]
+name = "windows_aarch64_gnullvm"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "41d2aa71f6f0cbe00ae5167d90ef3cfe66527d6f613ca78ac8024c3ccab9a19e"
+
+[[package]]
+name = "windows_aarch64_msvc"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "dd0f252f5a35cac83d6311b2e795981f5ee6e67eb1f9a7f64eb4500fbc4dcdb4"
+
+[[package]]
+name = "windows_i686_gnu"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "fbeae19f6716841636c28d695375df17562ca208b2b7d0dc47635a50ae6c5de7"
+
+[[package]]
+name = "windows_i686_msvc"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "84c12f65daa39dd2babe6e442988fc329d6243fdce47d7d2d155b8d874862246"
+
+[[package]]
+name = "windows_x86_64_gnu"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "bf7b1b21b5362cbc318f686150e5bcea75ecedc74dd157d874d754a2ca44b0ed"
+
+[[package]]
+name = "windows_x86_64_gnullvm"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "09d525d2ba30eeb3297665bd434a54297e4170c7f1a44cad4ef58095b4cd2028"
+
+[[package]]
+name = "windows_x86_64_msvc"
+version = "0.42.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "f40009d85759725a34da6d89a94e63d7bdc50a862acf0dbc7c8e488f1edcb6f5"
diff --git a/vendor/terminal_size/Cargo.toml b/vendor/terminal_size/Cargo.toml
new file mode 100644
index 000000000..8c729460f
--- /dev/null
+++ b/vendor/terminal_size/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "terminal_size"
+version = "0.2.3"
+authors = ["Andrew Chin <achin@eminence32.net>"]
+description = "Gets the size of your Linux or Windows terminal"
+documentation = "https://docs.rs/crate/terminal_size"
+readme = "README.md"
+keywords = [
+ "terminal",
+ "console",
+ "term",
+ "size",
+ "dimensions",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/eminence/terminal-size"
+
+[target."cfg(not(windows))".dependencies.rustix]
+version = "0.36.3"
+features = ["termios"]
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.42.0"
+features = [
+ "Win32_Foundation",
+ "Win32_System_Console",
+]
diff --git a/vendor/terminal_size/LICENSE-APACHE b/vendor/terminal_size/LICENSE-APACHE
new file mode 100644
index 000000000..8f71f43fe
--- /dev/null
+++ b/vendor/terminal_size/LICENSE-APACHE
@@ -0,0 +1,202 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "{}"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright {yyyy} {name of copyright owner}
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
diff --git a/vendor/terminal_size/LICENSE-MIT b/vendor/terminal_size/LICENSE-MIT
new file mode 100644
index 000000000..a05bf276d
--- /dev/null
+++ b/vendor/terminal_size/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2015 The terminal-size Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/vendor/terminal_size/README.md b/vendor/terminal_size/README.md
new file mode 100644
index 000000000..725723355
--- /dev/null
+++ b/vendor/terminal_size/README.md
@@ -0,0 +1,41 @@
+terminal-size
+=============
+
+
+[Documention](https://docs.rs/crate/terminal_size)
+
+
+Rust library to getting the size of your terminal.
+
+Works on Linux, MacOS, Windows, and illumos.
+
+```rust
+use terminal_size::{Width, Height, terminal_size};
+
+let size = terminal_size();
+if let Some((Width(w), Height(h))) = size {
+ println!("Your terminal is {} cols wide and {} lines tall", w, h);
+} else {
+ println!("Unable to get terminal size");
+}
+```
+
+## Minimum Rust Version
+
+This crate requires a minimum rust version of 1.48.0 (2020-11-19)
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or https://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or https://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally
+submitted for inclusion in the work by you, as defined in the Apache-2.0
+license, shall be dual licensed as above, without any additional terms or
+conditions.
diff --git a/vendor/terminal_size/examples/get_size.rs b/vendor/terminal_size/examples/get_size.rs
new file mode 100644
index 000000000..9039b429b
--- /dev/null
+++ b/vendor/terminal_size/examples/get_size.rs
@@ -0,0 +1,52 @@
+#[cfg(windows)]
+fn run() {
+ use std::os::windows::io::RawHandle;
+ use windows_sys::Win32::System::Console::{
+ GetStdHandle, STD_ERROR_HANDLE, STD_INPUT_HANDLE, STD_OUTPUT_HANDLE,
+ };
+
+ let stdout = unsafe { GetStdHandle(STD_OUTPUT_HANDLE) } as RawHandle;
+ println!(
+ "Size from terminal_size_using_handle(stdout): {:?}",
+ terminal_size::terminal_size_using_handle(stdout)
+ );
+
+ let stderr = unsafe { GetStdHandle(STD_ERROR_HANDLE) } as RawHandle;
+ println!(
+ "Size from terminal_size_using_handle(stderr): {:?}",
+ terminal_size::terminal_size_using_handle(stderr)
+ );
+
+ let stdin = unsafe { GetStdHandle(STD_INPUT_HANDLE) } as RawHandle;
+ println!(
+ "Size from terminal_size_using_handle(stdin): {:?}",
+ terminal_size::terminal_size_using_handle(stdin)
+ );
+}
+
+#[cfg(not(windows))]
+fn run() {
+ use std::os::unix::io::AsRawFd;
+
+ println!(
+ "Size from terminal_size_using_fd(stdout): {:?}",
+ terminal_size::terminal_size_using_fd(std::io::stdout().as_raw_fd())
+ );
+ println!(
+ "Size from terminal_size_using_fd(stderr): {:?}",
+ terminal_size::terminal_size_using_fd(std::io::stderr().as_raw_fd())
+ );
+ println!(
+ "Size from terminal_size_using_fd(stdin): {:?}",
+ terminal_size::terminal_size_using_fd(std::io::stdin().as_raw_fd())
+ );
+}
+
+fn main() {
+ println!(
+ "Size from terminal_size(): {:?}",
+ terminal_size::terminal_size()
+ );
+
+ run();
+}
diff --git a/vendor/terminal_size/src/lib.rs b/vendor/terminal_size/src/lib.rs
new file mode 100644
index 000000000..e933b2140
--- /dev/null
+++ b/vendor/terminal_size/src/lib.rs
@@ -0,0 +1,37 @@
+//! A simple utility for getting the size of a terminal.
+//!
+//! Supports both Linux, MacOS, and Windows.
+//!
+//! This crate requires a minimum rust version of 1.48.0 (2020-11-19)
+//!
+//! # Example
+//!
+//! ```
+//! use terminal_size::{Width, Height, terminal_size};
+//!
+//! let size = terminal_size();
+//! if let Some((Width(w), Height(h))) = size {
+//! println!("Your terminal is {} cols wide and {} lines tall", w, h);
+//! } else {
+//! println!("Unable to get terminal size");
+//! }
+//! ```
+//!
+
+#[derive(Debug, Clone, Copy, PartialEq, Eq, PartialOrd, Ord)]
+pub struct Width(pub u16);
+#[derive(Debug, Clone, Copy, PartialEq, Eq, PartialOrd, Ord)]
+pub struct Height(pub u16);
+
+#[cfg(unix)]
+mod unix;
+#[cfg(unix)]
+pub use crate::unix::{terminal_size, terminal_size_using_fd};
+
+#[cfg(windows)]
+mod windows;
+#[cfg(windows)]
+pub use crate::windows::{terminal_size, terminal_size_using_handle};
+
+#[cfg(not(any(unix, windows)))]
+pub fn terminal_size() -> Option<(Width, Height)> { None }
diff --git a/vendor/terminal_size/src/unix.rs b/vendor/terminal_size/src/unix.rs
new file mode 100644
index 000000000..59af979d0
--- /dev/null
+++ b/vendor/terminal_size/src/unix.rs
@@ -0,0 +1,111 @@
+use super::{Height, Width};
+use std::os::unix::io::RawFd;
+use rustix::fd::BorrowedFd;
+
+/// Returns the size of the terminal defaulting to STDOUT, if available.
+///
+/// If STDOUT is not a tty, returns `None`
+pub fn terminal_size() -> Option<(Width, Height)> {
+ terminal_size_using_fd(rustix::io::raw_stdout())
+}
+
+/// Returns the size of the terminal using the given file descriptor, if available.
+///
+/// If the given file descriptor is not a tty, returns `None`
+pub fn terminal_size_using_fd(fd: RawFd) -> Option<(Width, Height)> {
+ use rustix::termios::{isatty, tcgetwinsize};
+
+ // TODO: Once I/O safety is stabilized, the enlosing function here should
+ // be unsafe due to taking a `RawFd`. We should then move the main
+ // logic here into a new function which takes a `BorrowedFd` and is safe.
+ let fd = unsafe { BorrowedFd::borrow_raw(fd) };
+
+ if !isatty(fd) {
+ return None;
+ }
+
+ let winsize = tcgetwinsize(fd).ok()?;
+
+ let rows = winsize.ws_row;
+ let cols = winsize.ws_col;
+
+ if rows > 0 && cols > 0 {
+ Some((Width(cols), Height(rows)))
+ } else {
+ None
+ }
+}
+
+#[test]
+/// Compare with the output of `stty size`
+fn compare_with_stty() {
+ use std::process::Command;
+ use std::process::Stdio;
+
+ let (rows, cols) = if cfg!(target_os = "illumos") {
+ // illumos stty(1) does not accept a device argument, instead using
+ // stdin unconditionally:
+ let output = Command::new("stty")
+ .stdin(Stdio::inherit())
+ .output()
+ .unwrap();
+ assert!(output.status.success());
+
+ // stdout includes the row and columns thus: "rows = 80; columns = 24;"
+ let vals = String::from_utf8(output.stdout)
+ .unwrap()
+ .lines()
+ .map(|line| {
+ // Split each line on semicolons to get "k = v" strings:
+ line.split(';')
+ .map(str::trim)
+ .map(str::to_string)
+ .collect::<Vec<_>>()
+ })
+ .flatten()
+ .filter_map(|term| {
+ // split each "k = v" string and look for rows/columns:
+ match term.splitn(2, " = ").collect::<Vec<_>>().as_slice() {
+ ["rows", n] | ["columns", n] => Some(n.parse().unwrap()),
+ _ => None,
+ }
+ })
+ .collect::<Vec<_>>();
+ (vals[0], vals[1])
+ } else {
+ let output = if cfg!(target_os = "linux") {
+ Command::new("stty")
+ .arg("size")
+ .arg("-F")
+ .arg("/dev/stderr")
+ .stderr(Stdio::inherit())
+ .output()
+ .unwrap()
+ } else {
+ Command::new("stty")
+ .arg("-f")
+ .arg("/dev/stderr")
+ .arg("size")
+ .stderr(Stdio::inherit())
+ .output()
+ .unwrap()
+ };
+
+ assert!(output.status.success());
+ let stdout = String::from_utf8(output.stdout).unwrap();
+ // stdout is "rows cols"
+ let mut data = stdout.split_whitespace();
+ println!("{}", stdout);
+ let rows = u16::from_str_radix(data.next().unwrap(), 10).unwrap();
+ let cols = u16::from_str_radix(data.next().unwrap(), 10).unwrap();
+ (rows, cols)
+ };
+ println!("{} {}", rows, cols);
+
+ if let Some((Width(w), Height(h))) = terminal_size() {
+ assert_eq!(rows, h);
+ assert_eq!(cols, w);
+ } else {
+ panic!("terminal_size() return None");
+ }
+}
diff --git a/vendor/terminal_size/src/windows.rs b/vendor/terminal_size/src/windows.rs
new file mode 100644
index 000000000..74315d6ab
--- /dev/null
+++ b/vendor/terminal_size/src/windows.rs
@@ -0,0 +1,52 @@
+use super::{Height, Width};
+use std::os::windows::io::RawHandle;
+
+/// Returns the size of the terminal defaulting to STDOUT, if available.
+///
+/// Note that this returns the size of the actual command window, and
+/// not the overall size of the command window buffer
+pub fn terminal_size() -> Option<(Width, Height)> {
+ use windows_sys::Win32::System::Console::{GetStdHandle, STD_OUTPUT_HANDLE};
+
+ let handle = unsafe { GetStdHandle(STD_OUTPUT_HANDLE) as RawHandle };
+
+ terminal_size_using_handle(handle)
+}
+
+/// Returns the size of the terminal using the given handle, if available.
+///
+/// If the given handle is not a tty, returns `None`
+pub fn terminal_size_using_handle(handle: RawHandle) -> Option<(Width, Height)> {
+ use windows_sys::Win32::Foundation::INVALID_HANDLE_VALUE;
+ use windows_sys::Win32::System::Console::{
+ GetConsoleScreenBufferInfo, CONSOLE_SCREEN_BUFFER_INFO, COORD, SMALL_RECT,
+ };
+
+ // convert between windows_sys::Win32::Foundation::HANDLE and std::os::windows::raw::HANDLE
+ let hand = handle as windows_sys::Win32::Foundation::HANDLE;
+
+ if hand == INVALID_HANDLE_VALUE {
+ return None;
+ }
+
+ let zc = COORD { X: 0, Y: 0 };
+ let mut csbi = CONSOLE_SCREEN_BUFFER_INFO {
+ dwSize: zc,
+ dwCursorPosition: zc,
+ wAttributes: 0,
+ srWindow: SMALL_RECT {
+ Left: 0,
+ Top: 0,
+ Right: 0,
+ Bottom: 0,
+ },
+ dwMaximumWindowSize: zc,
+ };
+ if unsafe { GetConsoleScreenBufferInfo(hand, &mut csbi) } == 0 {
+ return None;
+ }
+
+ let w: Width = Width((csbi.srWindow.Right - csbi.srWindow.Left + 1) as u16);
+ let h: Height = Height((csbi.srWindow.Bottom - csbi.srWindow.Top + 1) as u16);
+ Some((w, h))
+}