summaryrefslogtreecommitdiffstats
path: root/vendor/textwrap/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/textwrap/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/textwrap/Cargo.toml')
-rw-r--r--vendor/textwrap/Cargo.toml82
1 files changed, 82 insertions, 0 deletions
diff --git a/vendor/textwrap/Cargo.toml b/vendor/textwrap/Cargo.toml
new file mode 100644
index 000000000..0e4c788e4
--- /dev/null
+++ b/vendor/textwrap/Cargo.toml
@@ -0,0 +1,82 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "textwrap"
+version = "0.15.0"
+authors = ["Martin Geisler <martin@geisler.net>"]
+exclude = [".github/", ".gitignore", "benches/", "examples/", "fuzz/", "images/"]
+description = "Powerful library for word wrapping, indenting, and dedenting strings"
+documentation = "https://docs.rs/textwrap/"
+readme = "README.md"
+keywords = ["text", "formatting", "wrap", "typesetting", "hyphenation"]
+categories = ["text-processing", "command-line-interface"]
+license = "MIT"
+repository = "https://github.com/mgeisler/textwrap"
+[package.metadata.docs.rs]
+all-features = true
+
+[[example]]
+name = "hyphenation"
+path = "examples/hyphenation.rs"
+required-features = ["hyphenation"]
+
+[[example]]
+name = "termwidth"
+path = "examples/termwidth.rs"
+required-features = ["terminal_size"]
+
+[[bench]]
+name = "linear"
+path = "benches/linear.rs"
+harness = false
+
+[[bench]]
+name = "indent"
+path = "benches/indent.rs"
+harness = false
+[dependencies.hyphenation]
+version = "0.8.4"
+features = ["embed_en-us"]
+optional = true
+
+[dependencies.smawk]
+version = "0.3.1"
+optional = true
+
+[dependencies.terminal_size]
+version = "0.1.17"
+optional = true
+
+[dependencies.unicode-linebreak]
+version = "0.1.2"
+optional = true
+
+[dependencies.unicode-width]
+version = "0.1.9"
+optional = true
+[dev-dependencies.criterion]
+version = "0.3.5"
+
+[dev-dependencies.lipsum]
+version = "0.8.0"
+
+[dev-dependencies.unic-emoji-char]
+version = "0.9.0"
+
+[dev-dependencies.version-sync]
+version = "0.9.4"
+
+[features]
+default = ["unicode-linebreak", "unicode-width", "smawk"]
+[target."cfg(unix)".dev-dependencies.termion]
+version = "1.5.6"