summaryrefslogtreecommitdiffstats
path: root/vendor/thorin-dwp
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/thorin-dwp
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/thorin-dwp')
-rw-r--r--vendor/thorin-dwp/.cargo-checksum.json2
-rw-r--r--vendor/thorin-dwp/Cargo.toml4
-rw-r--r--vendor/thorin-dwp/README.md2
-rw-r--r--vendor/thorin-dwp/src/lib.rs2
4 files changed, 6 insertions, 4 deletions
diff --git a/vendor/thorin-dwp/.cargo-checksum.json b/vendor/thorin-dwp/.cargo-checksum.json
index 1cbdb54a1..0f21c222b 100644
--- a/vendor/thorin-dwp/.cargo-checksum.json
+++ b/vendor/thorin-dwp/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"989f60194ba1f0f9b1862bf0b264f466c45794ba39c6443bea09a8bcbedaec2c","README.md":"791a75e565f7cb2effc72408cfc2d6ccb0b54c3385115b342345594f3e5fb6d2","src/error.rs":"7eccbcddfc8694392e7c79e5346c95feb1ea7bd8818de4f59316533cb801518a","src/ext.rs":"a385d1fd8f2102c66a8d5986a2899189a1139683cf6267f63978074867e9a18a","src/index.rs":"060c5c5453e9ec9f2641d4b9d1e8b32dfaf9025510b8fa8d531dd3578640b2d1","src/lib.rs":"e23d466e66b1c959832569ea17c791aafe92b1bebd32bb1d1c59dca173b87d8e","src/package.rs":"43cf081749d232baf60a65a65478e68fc708d8bf308a5b29bd24cfa4120a7ebc","src/relocate.rs":"6a9d7e123bb6d0934847209a1192ed2a23a0502d32a1ccfceccf40726f469618","src/strings.rs":"fb85d8650bccd843bcf5145d8b06a1beec1332eb2b4f7aef9a09f88172ba2688"},"package":"da8fbf660a019b6bf11ea95762041464aa9099cc293b6a66d77cea5107619671"} \ No newline at end of file
+{"files":{"Cargo.toml":"a217c74074725c62fc48d1275978c4bd46117b10cca13526c3de0a57f3be0f5f","README.md":"296c8b1a00a5d53f5c3df1b60047763b3d38e1f28ff98bf58ec07a95cabf78f2","src/error.rs":"7eccbcddfc8694392e7c79e5346c95feb1ea7bd8818de4f59316533cb801518a","src/ext.rs":"a385d1fd8f2102c66a8d5986a2899189a1139683cf6267f63978074867e9a18a","src/index.rs":"060c5c5453e9ec9f2641d4b9d1e8b32dfaf9025510b8fa8d531dd3578640b2d1","src/lib.rs":"25bcb38b09c174fd37004684af0989827ce3bb223b6b25874c687b7ad44408e6","src/package.rs":"43cf081749d232baf60a65a65478e68fc708d8bf308a5b29bd24cfa4120a7ebc","src/relocate.rs":"6a9d7e123bb6d0934847209a1192ed2a23a0502d32a1ccfceccf40726f469618","src/strings.rs":"fb85d8650bccd843bcf5145d8b06a1beec1332eb2b4f7aef9a09f88172ba2688"},"package":"98c040e1340b889d4180c64e1d787efa9c32cb1617757e101480b61238b0d927"} \ No newline at end of file
diff --git a/vendor/thorin-dwp/Cargo.toml b/vendor/thorin-dwp/Cargo.toml
index 3635bcd50..99ff2bea5 100644
--- a/vendor/thorin-dwp/Cargo.toml
+++ b/vendor/thorin-dwp/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "thorin-dwp"
-version = "0.4.0"
+version = "0.6.0"
authors = ["David Wood <david.wood@huawei.com>"]
description = "Library for building DWARF packages from input DWARF objects and packages"
homepage = "https://docs.rs/thorin-dwp"
@@ -46,7 +46,7 @@ default-features = false
version = "0.12.0"
[dependencies.object]
-version = "0.30.0"
+version = "0.31.0"
features = [
"archive",
"read",
diff --git a/vendor/thorin-dwp/README.md b/vendor/thorin-dwp/README.md
index ae3b8099c..7ca3ca685 100644
--- a/vendor/thorin-dwp/README.md
+++ b/vendor/thorin-dwp/README.md
@@ -12,7 +12,7 @@ cross-crate Split DWARF packaging in `rustc`.
To use `thorin` in your own project, add it to your `Cargo.toml`:
```toml
-thorin-dwp = "0.4.0"
+thorin-dwp = "0.6.0"
```
See the [`thorin-bin`](../thorin-bin/README.md) crate for an example of using `thorin`'s library
diff --git a/vendor/thorin-dwp/src/lib.rs b/vendor/thorin-dwp/src/lib.rs
index b084aa311..dcd6b4e42 100644
--- a/vendor/thorin-dwp/src/lib.rs
+++ b/vendor/thorin-dwp/src/lib.rs
@@ -1,3 +1,5 @@
+pub extern crate object;
+
use std::{
borrow::Cow,
collections::HashSet,