summaryrefslogtreecommitdiffstats
path: root/vendor/thread_local/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/thread_local/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/thread_local/Cargo.toml')
-rw-r--r--vendor/thread_local/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/vendor/thread_local/Cargo.toml b/vendor/thread_local/Cargo.toml
new file mode 100644
index 000000000..90e53190d
--- /dev/null
+++ b/vendor/thread_local/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "thread_local"
+version = "1.1.4"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "Per-object thread-local storage"
+documentation = "https://docs.rs/thread_local/"
+readme = "README.md"
+keywords = ["thread_local", "concurrent", "thread"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/Amanieu/thread_local-rs"
+
+[[bench]]
+name = "thread_local"
+harness = false
+required-features = ["criterion"]
+[dependencies.criterion]
+version = "0.3.3"
+optional = true
+
+[dependencies.once_cell]
+version = "1.5.2"
+
+[dev-dependencies]
+[badges.travis-ci]
+repository = "Amanieu/thread_local-rs"