summaryrefslogtreecommitdiffstats
path: root/vendor/time/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/time/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/time/Cargo.toml')
-rw-r--r--vendor/time/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/vendor/time/Cargo.toml b/vendor/time/Cargo.toml
index 8ff2173f6..6423b7416 100644
--- a/vendor/time/Cargo.toml
+++ b/vendor/time/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.60.0"
+rust-version = "1.63.0"
name = "time"
-version = "0.3.17"
+version = "0.3.20"
authors = [
"Jacob Pratt <open-source@jhpratt.dev>",
"Time contributors",
@@ -43,11 +43,11 @@ repository = "https://github.com/time-rs/time"
[package.metadata.docs.rs]
all-features = true
-targets = ["x86_64-unknown-linux-gnu"]
rustdoc-args = [
"--cfg",
"__time_03_docs",
]
+targets = ["x86_64-unknown-linux-gnu"]
[lib]
bench = false
@@ -84,7 +84,7 @@ default-features = false
version = "=0.1.0"
[dependencies.time-macros]
-version = "=0.2.6"
+version = "=0.2.8"
optional = true
[dev-dependencies.quickcheck_macros]
@@ -106,7 +106,7 @@ version = "1.0.68"
version = "1.0.126"
[dev-dependencies.time-macros]
-version = "=0.2.6"
+version = "=0.2.8"
[features]
alloc = ["serde?/alloc"]
@@ -149,7 +149,7 @@ wasm-bindgen = ["dep:js-sys"]
[target."cfg(__ui_tests)".dev-dependencies.trybuild]
version = "1.0.68"
-[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys]
+[target."cfg(all(target_family = \"wasm\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys]
version = "0.3.58"
optional = true