summaryrefslogtreecommitdiffstats
path: root/vendor/tinystr/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:21 +0000
commit4e8199b572f2035b7749cba276ece3a26630d23e (patch)
treef09feeed6a0fe39d027b1908aa63ea6b35e4b631 /vendor/tinystr/Cargo.toml
parentAdding upstream version 1.66.0+dfsg1. (diff)
downloadrustc-4e8199b572f2035b7749cba276ece3a26630d23e.tar.xz
rustc-4e8199b572f2035b7749cba276ece3a26630d23e.zip
Adding upstream version 1.67.1+dfsg1.upstream/1.67.1+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tinystr/Cargo.toml')
-rw-r--r--vendor/tinystr/Cargo.toml108
1 files changed, 90 insertions, 18 deletions
diff --git a/vendor/tinystr/Cargo.toml b/vendor/tinystr/Cargo.toml
index 53f9fc1f7..64682f74e 100644
--- a/vendor/tinystr/Cargo.toml
+++ b/vendor/tinystr/Cargo.toml
@@ -3,40 +3,112 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "tinystr"
-version = "0.3.4"
-authors = ["Raph Levien <raph.levien@gmail.com>", "Zibi Braniecki <zibi@braniecki.net>"]
-description = "A small ASCII-only bounded length string representation.\n"
-readme = "README.md"
-keywords = ["string", "str", "small", "tiny", "no_std"]
+version = "0.7.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "A small ASCII-only bounded length string representation."
+keywords = [
+ "string",
+ "str",
+ "small",
+ "tiny",
+ "no_std",
+]
categories = ["data-structures"]
-license = "Apache-2.0/MIT"
-repository = "https://github.com/zbraniecki/tinystr"
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[[test]]
+name = "serde"
+required-features = ["serde"]
+
+[[bench]]
+name = "overview"
+harness = false
[[bench]]
name = "construct"
harness = false
+required-features = ["bench"]
[[bench]]
-name = "tinystr"
+name = "read"
harness = false
-[dependencies.tinystr-macros]
+required-features = ["bench"]
+
+[[bench]]
+name = "serde"
+harness = false
+required-features = [
+ "bench",
+ "serde",
+]
+
+[dependencies.databake]
version = "0.1"
optional = true
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.serde]
+version = "1.0.123"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.zerovec]
+version = "0.9"
+optional = true
+
+[dev-dependencies.bincode]
+version = "1.3"
+
[dev-dependencies.criterion]
version = "0.3"
+[dev-dependencies.postcard]
+version = "1.0.0"
+features = ["use-std"]
+
+[dev-dependencies.rand]
+version = "0.8.5"
+features = ["small_rng"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+features = ["alloc"]
+default-features = false
+
+[dev-dependencies.tinystr_old]
+version = "0.4"
+features = ["serde"]
+package = "tinystr"
+
[features]
alloc = []
-default = ["std"]
-macros = ["tinystr-macros"]
-std = []
+bench = []
+default = ["alloc"]
+zerovec = ["dep:zerovec"]