summaryrefslogtreecommitdiffstats
path: root/vendor/tokio-util/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:24 +0000
commit023939b627b7dc93b01471f7d41fb8553ddb4ffa (patch)
tree60fc59477c605c72b0a1051409062ddecc43f877 /vendor/tokio-util/Cargo.toml
parentAdding debian version 1.72.1+dfsg1-1. (diff)
downloadrustc-023939b627b7dc93b01471f7d41fb8553ddb4ffa.tar.xz
rustc-023939b627b7dc93b01471f7d41fb8553ddb4ffa.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tokio-util/Cargo.toml')
-rw-r--r--vendor/tokio-util/Cargo.toml112
1 files changed, 112 insertions, 0 deletions
diff --git a/vendor/tokio-util/Cargo.toml b/vendor/tokio-util/Cargo.toml
new file mode 100644
index 000000000..001b0b78b
--- /dev/null
+++ b/vendor/tokio-util/Cargo.toml
@@ -0,0 +1,112 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49"
+name = "tokio-util"
+version = "0.7.2"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = """
+Additional utilities for working with Tokio.
+"""
+homepage = "https://tokio.rs"
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.bytes]
+version = "1.0.0"
+
+[dependencies.futures-core]
+version = "0.3.0"
+
+[dependencies.futures-io]
+version = "0.3.0"
+optional = true
+
+[dependencies.futures-sink]
+version = "0.3.0"
+
+[dependencies.futures-util]
+version = "0.3.0"
+optional = true
+
+[dependencies.pin-project-lite]
+version = "0.2.0"
+
+[dependencies.slab]
+version = "0.4.4"
+optional = true
+
+[dependencies.tokio]
+version = "1.7.0"
+features = ["sync"]
+
+[dependencies.tracing]
+version = "0.1.25"
+optional = true
+
+[dev-dependencies.async-stream]
+version = "0.3.0"
+
+[dev-dependencies.futures]
+version = "0.3.0"
+
+[dev-dependencies.futures-test]
+version = "0.3.5"
+
+[dev-dependencies.tokio]
+version = "1.0.0"
+features = ["full"]
+
+[dev-dependencies.tokio-stream]
+version = "0.1"
+
+[dev-dependencies.tokio-test]
+version = "0.4.0"
+
+[features]
+__docs_rs = ["futures-util"]
+codec = ["tracing"]
+compat = ["futures-io"]
+default = []
+full = [
+ "codec",
+ "compat",
+ "io-util",
+ "time",
+ "net",
+ "rt",
+]
+io = []
+io-util = [
+ "io",
+ "tokio/rt",
+ "tokio/io-util",
+]
+net = ["tokio/net"]
+rt = [
+ "tokio/rt",
+ "tokio/sync",
+ "futures-util",
+]
+time = [
+ "tokio/time",
+ "slab",
+]