summaryrefslogtreecommitdiffstats
path: root/vendor/tokio/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/tokio/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tokio/Cargo.toml')
-rw-r--r--vendor/tokio/Cargo.toml131
1 files changed, 131 insertions, 0 deletions
diff --git a/vendor/tokio/Cargo.toml b/vendor/tokio/Cargo.toml
new file mode 100644
index 000000000..11ec0c0bd
--- /dev/null
+++ b/vendor/tokio/Cargo.toml
@@ -0,0 +1,131 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tokio"
+version = "1.8.4"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
+homepage = "https://tokio.rs"
+documentation = "https://docs.rs/tokio/1.8.4/tokio/"
+readme = "README.md"
+keywords = ["io", "async", "non-blocking", "futures"]
+categories = ["asynchronous", "network-programming"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[package.metadata.playground]
+features = ["full", "test-util"]
+[dependencies.bytes]
+version = "1.0.0"
+optional = true
+
+[dependencies.memchr]
+version = "2.2"
+optional = true
+
+[dependencies.mio]
+version = "0.7.6"
+optional = true
+
+[dependencies.num_cpus]
+version = "1.8.0"
+optional = true
+
+[dependencies.once_cell]
+version = "1.5.2"
+optional = true
+
+[dependencies.parking_lot]
+version = "0.11.0"
+optional = true
+
+[dependencies.pin-project-lite]
+version = "0.2.0"
+
+[dependencies.tokio-macros]
+version = "1.1.0"
+optional = true
+[dev-dependencies.async-stream]
+version = "0.3"
+
+[dev-dependencies.futures]
+version = "0.3.0"
+features = ["async-await"]
+
+[dev-dependencies.mockall]
+version = "0.10.2"
+
+[dev-dependencies.proptest]
+version = "1"
+
+[dev-dependencies.rand]
+version = "0.8.0"
+
+[dev-dependencies.socket2]
+version = "0.4"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[dev-dependencies.tokio-stream]
+version = "0.1"
+
+[dev-dependencies.tokio-test]
+version = "0.4.0"
+[build-dependencies.autocfg]
+version = "1"
+
+[features]
+default = []
+fs = []
+full = ["fs", "io-util", "io-std", "macros", "net", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "sync", "time"]
+io-std = []
+io-util = ["memchr", "bytes"]
+macros = ["tokio-macros"]
+net = ["libc", "mio/os-poll", "mio/os-util", "mio/tcp", "mio/udp", "mio/uds", "winapi/namedpipeapi"]
+process = ["bytes", "once_cell", "libc", "mio/os-poll", "mio/os-util", "mio/uds", "signal-hook-registry", "winapi/threadpoollegacyapiset"]
+rt = []
+rt-multi-thread = ["num_cpus", "rt"]
+signal = ["once_cell", "libc", "mio/os-poll", "mio/uds", "mio/os-util", "signal-hook-registry", "winapi/consoleapi"]
+sync = []
+test-util = []
+time = []
+[target."cfg(loom)".dev-dependencies.loom]
+version = "0.5"
+features = ["futures", "checkpoint"]
+[target."cfg(tokio_unstable)".dependencies.tracing]
+version = "0.1.21"
+features = ["std"]
+optional = true
+default-features = false
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.42"
+optional = true
+
+[target."cfg(unix)".dependencies.signal-hook-registry]
+version = "1.1.1"
+optional = true
+[target."cfg(unix)".dev-dependencies.libc]
+version = "0.2.42"
+
+[target."cfg(unix)".dev-dependencies.nix]
+version = "0.22.0"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.8"
+optional = true
+default-features = false
+[target."cfg(windows)".dev-dependencies.ntapi]
+version = "0.3.6"